p PatchFirst

CVE-2021-3481

CVE-2021-3481

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A flaw was found in Qt. An out-of-bounds read vulnerability was found in QRadialFetchSimd in qt/qtbase/src/gui/painting/qdrawhelper_p.h in Qt/Qtbase. While rendering and displaying a crafted Scalable Vector Graphics (SVG) file this flaw may lead to an unauthorized memory access. The highest threat from this vulnerability is to data confidentiality and the application availability.

CVSS 7.1 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • qt

    Версии
    • Fixed in qt 5.12.11, qt 5.15.4, qt 6.0.3, qt 6.1.0RC.: Затронуто

    Нет опубликованного исправления

  • qtsvg-opensource-src Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.15.2-3

    Обновитесь до 5.15.2-3

  • qtsvg-opensource-src Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.15.2-3

    Обновитесь до 5.15.2-3

  • qtsvg-opensource-src Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.15.2-3

    Обновитесь до 5.15.2-3

  • qt4-x11 Ubuntu:14.04:LTS

    Версии
    • 4:4.8.4+dfsg-0ubuntu18
    • 4:4.8.4+dfsg-0ubuntu19
    • 4:4.8.4+dfsg-0ubuntu20
    • 4:4.8.4+dfsg-0ubuntu21
    • 4:4.8.4+dfsg-0ubuntu22
    • 4:4.8.5+git192-g085f851+dfsg-2ubuntu3
    • 4:4.8.5+git192-g085f851+dfsg-2ubuntu4
    • 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • qt4-x11 Ubuntu:16.04:LTS

    Версии
    • 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8
    • 4:4.8.7+dfsg-5ubuntu1
    • 4:4.8.7+dfsg-5ubuntu2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • qtsvg-opensource-src Ubuntu:Pro:16.04:LTS

    Версии
    • 5.4.2-2build1
    • 5.5.1-2build1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.5.1-2ubuntu0.1~esm1

    Обновитесь до 5.5.1-2ubuntu0.1~esm1

  • qtsvg-opensource-src Ubuntu:18.04:LTS

    Версии
    • 5.9.1-2
    • 5.9.2-2
    • 5.9.2-3
    • 5.9.3-0ubuntu1
    • 5.9.4-0ubuntu1
    • 5.9.5-0ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.9.5-0ubuntu1.1

    Обновитесь до 5.9.5-0ubuntu1.1

  • qt4-x11 Ubuntu:18.04:LTS

    Версии
    • 4:4.8.7+dfsg-7ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • qtsvg-opensource-src Ubuntu:Pro:20.04:LTS

    Версии
    • 5.12.4-1
    • 5.12.5-2
    • 5.12.5-2build1
    • 5.12.8-0ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.12.8-0ubuntu1+esm1

    Обновитесь до 5.12.8-0ubuntu1+esm1

Первоисточники

Проверьте свой сервер →