p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости qt4-x11

За последние 30 дней в qt4-x11 опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 19

  1. CVE-2026-15037

    Низкий · CVSS 2.9EPSS 0,44%Нет опубликованного исправления

    XML injection vulnerability in QDom comment, CDATA and processing-instruction serialization

    Improper output neutralization (XML injection) in QDom comment, CDATA, and processing-instruction serialization in Qt XML from 4.0.0 through 6.11 allows untrusted text serialized by an application into those nodes to inject arbitrary XML markup, because the node terminators are not escaped under the default InvalidDataPolicy (AcceptInvalidChars). Fixed in Qt 6.12.

    Опубликовано Обновлено
  2. CVE-2023-43114

    Средний · CVSS 5.5EPSS 0,27%Нет опубликованного исправления

    CVE-2023-43114

    An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.

    Опубликовано Обновлено
  3. CVE-2023-37369

    Высокий · CVSS 7.5EPSS 1,58%Нет опубликованного исправления

    CVE-2023-37369

    In Qt before 5.15.15, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.2, there can be an application crash in QXmlStreamReader via a crafted XML string that triggers a situation in which a prefix is greater than a length.

    Опубликовано Обновлено
  4. CVE-2023-34410

    Средний · CVSS 5.3EPSS 0,74%Нет опубликованного исправления

    CVE-2023-34410

    An issue was discovered in Qt before 5.15.15, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.2. Certificate validation for TLS does not always consider whether the root of a chain is a configured CA certificate.

  5. CVE-2021-3481

    Высокий · CVSS 7.1EPSS 0,54%Нет опубликованного исправления

    CVE-2021-3481

    A flaw was found in Qt. An out-of-bounds read vulnerability was found in QRadialFetchSimd in qt/qtbase/src/gui/painting/qdrawhelper_p.h in Qt/Qtbase. While rendering and displaying a crafted Scalable Vector Graphics (SVG) file this flaw may lead to an unauthorized memory access. The highest threat from this vulnerability is to data confidentiality and the application availability.

    Опубликовано Обновлено
  6. CVE-2020-17507

    Средний · CVSS 5.3EPSS 3,99%Нет опубликованного исправления

    CVE-2020-17507

    An issue was discovered in Qt through 5.12.9, and 5.13.x through 5.15.x before 5.15.1. read_xbm_body in gui/image/qxbmhandler.cpp has a buffer over-read.

    Опубликовано Обновлено
  7. CVE-2015-9541

    Высокий · CVSS 7.5EPSS 2,59%Нет опубликованного исправления

    CVE-2015-9541

    Qt through 5.14 allows an exponential XML entity expansion attack via a crafted SVG document that is mishandled in QXmlStreamReader, a related issue to CVE-2003-1564.

    Опубликовано Обновлено
  8. CVE-2017-10905

    Средний · CVSS 5.3EPSS 0,58%Нет опубликованного исправления

    CVE-2017-10905

    A vulnerability in applications created using Qt for Android prior to 5.9.3 allows attackers to alter environment variables via unspecified vectors.

    Опубликовано Обновлено
  9. CVE-2016-10040

    Средний · CVSS 5.5EPSS 1,92%Нет опубликованного исправления

    CVE-2016-10040

    Stack-based buffer overflow in QXmlSimpleReader in Qt 4.8.5 allows remote attackers to cause a denial of service (application crash) via a xml file with multiple nested open tags.

    Опубликовано Обновлено
  10. CVE-2015-1860

    Без оценкиEPSS 8,34%Есть исправление

    CVE-2015-1860

    Multiple buffer overflows in gui/image/qgifhandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a crafted GIF image.

    • Обновитесь до 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
  11. CVE-2015-1859

    Без оценкиEPSS 6,54%Есть исправление

    CVE-2015-1859

    Multiple buffer overflows in plugins/imageformats/ico/qicohandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted ICO image.

    • Обновитесь до 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
  12. CVE-2015-1858

    Без оценкиEPSS 6,57%Есть исправление

    CVE-2015-1858

    Multiple buffer overflows in gui/image/qbmphandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted BMP image.

    • Обновитесь до 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
  13. CVE-2015-0295

    Без оценкиEPSS 6,07%Есть исправление

    CVE-2015-0295

    The BMP decoder in QtGui in QT before 5.5 does not properly calculate the masks used to extract the color components, which allows remote attackers to cause a denial of service (divide-by-zero and crash) via a crafted BMP file.

    • Обновитесь до 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Опубликовано Обновлено
  14. CVE-2014-0190

    Без оценкиEPSS 3,96%Есть исправление

    CVE-2014-0190

    The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

    • Обновитесь до 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
  15. CVE-2013-4549

    Без оценкиEPSS 3,1%Есть исправление

    CVE-2013-4549

    QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

    • Обновитесь до 4:4.8.4+dfsg-0ubuntu20
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →