p PatchFirst

CVE-2022-41556

CVE-2022-41556

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

CVSS 7.5 · Высокий · EPSS 3,8% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • lighttpd Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.67-1

    Обновитесь до 1.4.67-1

  • lighttpd Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.67-1

    Обновитесь до 1.4.67-1

  • lighttpd Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.67-1

    Обновитесь до 1.4.67-1

  • lighttpd Ubuntu:Pro:14.04:LTS

    Версии
    • 1.4.31-3ubuntu3
    • 1.4.33-1ubuntu1
    • 1.4.33-1+nmu2ubuntu1
    • 1.4.33-1+nmu2ubuntu2
    • 1.4.33-1+nmu2ubuntu2.1
    • 1.4.33-1+nmu2ubuntu2.1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • lighttpd Ubuntu:22.04:LTS

    Версии
    • 1.4.59-1ubuntu2
    • 1.4.59-1ubuntu3
    • 1.4.63-1ubuntu1
    • 1.4.63-1ubuntu2
    • 1.4.63-1ubuntu3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.63-1ubuntu3.1

    Обновитесь до 1.4.63-1ubuntu3.1

Первоисточники

Проверьте свой сервер →