p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости lighttpd

За последние 30 дней в lighttpd опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 5

  1. CVE-2025-12642

    Средний · CVSS 6.9EPSS 0,37%Нет опубликованного исправления

    HTTP Header Smuggling via Trailer Merge

    lighttpd1.4.80 incorrectly merged trailer fields into headers after http request parsing. This behavior can be exploited to conduct HTTP Header Smuggling attacks. Successful exploitation may allow an attacker to: * Bypass access control rules * Inject unsafe input into backend logic that trusts request headers * Execute HTTP Request Smuggling attacks under some conditions This issue affects lighttpd1.4.80

    Опубликовано Обновлено
  2. CVE-2025-8671

    Высокий · CVSS 7.5EPSS 3,62%Нет опубликованного исправления

    CVE-2025-8671

    A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to denial-of-service (DoS). By opening streams and then rapidly triggering the server to reset them—using malformed frames or flow control errors—an attacker can exploit incorrect stream accounting. Streams reset by the server are considered closed at the protocol level, even though backend processing continues. This allows a client to cause the server to handle an unbounded number of concurrent streams on a single connection. Th

    Опубликовано Обновлено
  3. CVE-2022-41556

    Высокий · CVSS 7.5EPSS 3,83%Есть исправление

    CVE-2022-41556

    A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

    • Обновитесь до 1.4.63-1ubuntu3.1
    Опубликовано Обновлено
  4. CVE-2022-37797

    Высокий · CVSS 7.5EPSS 2,55%Нет опубликованного исправления

    CVE-2022-37797

    In lighttpd 1.4.65, mod_wstunnel does not initialize a handler function pointer if an invalid HTTP request (websocket handshake) is received. It leads to null pointer dereference which crashes the server. It could be used by an external attacker to cause denial of service condition.

    Опубликовано Обновлено
  5. CVE-2022-22707

    Средний · CVSS 5.9EPSS 8,93%Есть исправление

    CVE-2022-22707

    In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

    • Обновитесь до 1.4.63-1ubuntu3.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →