CVE-2026-116687
CVE-2026-116687 · CKEditor: Cross-site scripting (XSS) in the engine package
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.
CVSS 3.1 · Низкий · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
ckeditor5
- Версии
- >= 29.0.0, < 47.7.4: Затронуто
- >= 48.0.0, < 48.5.1: Затронуто
Нет опубликованного исправления
ckeditor5 npm
- Затронутые диапазоны версий
- SEMVER: ≥ 29.0.0, < 47.7.4
Обновитесь до 47.7.4
@ckeditor/ckeditor5-engine npm
- Затронутые диапазоны версий
- SEMVER: ≥ 29.0.0, < 47.7.4
Обновитесь до 47.7.4
ckeditor5 npm
- Затронутые диапазоны версий
- SEMVER: ≥ 48.0.0, < 48.5.1
Обновитесь до 48.5.1
@ckeditor/ckeditor5-engine npm
- Затронутые диапазоны версий
- SEMVER: ≥ 48.0.0, < 48.5.1
Обновитесь до 48.5.1
ckeditor Ubuntu:Pro:16.04:LTS
- Версии
- 4.4.4+dfsg1-3
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.7+dfsg-2
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm1
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm2
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ldap-account-manager Ubuntu:16.04:LTS
- Версии
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
request-tracker4 Ubuntu:16.04:LTS
- Версии
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor Ubuntu:Pro:18.04:LTS
- Версии
- 4.5.7+dfsg-2
- 4.5.7+dfsg-2ubuntu0.18.04.1
- 4.5.7+dfsg-2ubuntu0.18.04.1+esm1
- 4.5.7+dfsg-2ubuntu0.18.04.1+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor3 Ubuntu:18.04:LTS
- Версии
- 3.6.6.1+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ldap-account-manager Ubuntu:18.04:LTS
- Версии
- 5.7-1
- 6.1-1
- 6.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
request-tracker4 Ubuntu:Pro:18.04:LTS
- Версии
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor Ubuntu:Pro:20.04:LTS
- Версии
- 4.11.1+dfsg-1
- 4.12.1+dfsg-1
- 4.12.1+dfsg-1ubuntu0.1
- 4.12.1+dfsg-1ubuntu0.1+esm1
- 4.12.1+dfsg-1ubuntu0.1+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor3 Ubuntu:20.04:LTS
- Версии
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ldap-account-manager Ubuntu:20.04:LTS
- Версии
- 6.7-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
request-tracker4 Ubuntu:20.04:LTS
- Версии
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor3 Ubuntu:22.04:LTS
- Версии
- 3.6.6.1+dfsg-7
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ldap-account-manager Ubuntu:22.04:LTS
- Версии
- 7.5-1
- 7.7-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
request-tracker4 Ubuntu:22.04:LTS
- Версии
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor Ubuntu:Pro:22.04:LTS
- Версии
- 4.16.0+dfsg-2
- 4.16.2+dfsg-1
- 4.16.2+dfsg-1ubuntu0.1~esm1
- 4.16.2+dfsg-1ubuntu0.1~esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor3 Ubuntu:24.04:LTS
- Версии
- 3.6.6.1+dfsg-7
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ldap-account-manager Ubuntu:24.04:LTS
- Версии
- 8.3-1
- 8.5-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
request-tracker4 Ubuntu:24.04:LTS
- Версии
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ckeditor Ubuntu:Pro:24.04:LTS
- Версии
- 4.22.1+dfsg1-2
- 4.22.1+dfsg1-2ubuntu0.24.04.1~esm1
- 4.22.1+dfsg1-2ubuntu0.24.04.1~esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-v6mg-96c6-gmpq
- https://github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0
- https://github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423
- https://github.com/ckeditor/ckeditor5/releases/tag/v47.7.4
- https://github.com/ckeditor/ckeditor5/releases/tag/v48.5.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-116687