CVE-2026-12957
CVE-2026-12957 · Arbitrary Code Execution in Language Servers for AWS
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
CVSS 8.5 · Высокий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
language servers for aws
- Версии
- ≥ 0, < 1.65.0: Затронуто (semver)
Обновитесь до 1.65.0
@aws/lsp-codewhisperer npm
- Затронутые диапазоны версий
- SEMVER: < 0.0.113
Обновитесь до 0.0.113