p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости @aws/lsp-codewhisperer

За последние 30 дней в @aws/lsp-codewhisperer опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 2

  1. CVE-2026-12958

    Высокий · CVSS 8.5EPSS 0,19%Есть исправление

    Arbitrary file write in Language Servers for AWS

    Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.

    • Обновитесь до 0.0.117
  2. CVE-2026-12957

    Высокий · CVSS 8.5EPSS 0,23%Есть исправление

    Arbitrary Code Execution in Language Servers for AWS

    Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

    • Обновитесь до 0.0.113

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →