CVE-2026-32327
CVE-2026-32327 · Apache Portable Runtime Utility: apr-util XML stack recursion crash
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.
CVSS 9.1 · Критический · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache portable runtime utility
- Версии
- ≥ 0, ≤ 1.6.3: Затронуто (semver)
Нет опубликованного исправления
apr-util Debian:12
- Версии
- 1.6.3-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.3-1+deb12u1
Обновитесь до 1.6.3-1+deb12u1
apr-util Debian:13
- Версии
- 1.6.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.3-3+deb13u1
Обновитесь до 1.6.3-3+deb13u1
apr-util Debian:14
- Версии
- 1.6.3-3
- 1.6.3-4
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.4-1
Обновитесь до 1.6.4-1
apr-util Ubuntu:Pro:14.04:LTS
- Версии
- 1.5.2-1
- 1.5.2-1build1
- 1.5.2-2ubuntu1
- 1.5.3-1
- 1.5.3-1ubuntu0.1~esm1
- 1.5.3-1ubuntu0.1~esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.3-1ubuntu0.1~esm3
Обновитесь до 1.5.3-1ubuntu0.1~esm3
apr-util Ubuntu:Pro:18.04:LTS
- Версии
- 1.6.0-2
- 1.6.1-1
- 1.6.1-1ubuntu2
- 1.6.1-2
- 1.6.1-2ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1-2ubuntu0.1+esm1
Обновитесь до 1.6.1-2ubuntu0.1+esm1
apr-util Ubuntu:Pro:20.04:LTS
- Версии
- 1.6.1-4build1
- 1.6.1-4ubuntu1
- 1.6.1-4ubuntu2
- 1.6.1-4ubuntu2.1
- 1.6.1-4ubuntu2.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1-4ubuntu2.2+esm1
Обновитесь до 1.6.1-4ubuntu2.2+esm1
apr-util Ubuntu:22.04:LTS
- Версии
- 1.6.1-5ubuntu2
- 1.6.1-5ubuntu3
- 1.6.1-5ubuntu4
- 1.6.1-5ubuntu4.22.04.1
- 1.6.1-5ubuntu4.22.04.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1-5ubuntu4.22.04.3
Обновитесь до 1.6.1-5ubuntu4.22.04.3
apr-util Ubuntu:24.04:LTS
- Версии
- 1.6.3-1ubuntu1
- 1.6.3-1.1ubuntu5
- 1.6.3-1.1ubuntu6
- 1.6.3-1.1ubuntu7
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.3-1.1ubuntu7.1
Обновитесь до 1.6.3-1.1ubuntu7.1
apr-util Ubuntu:26.04:LTS
- Версии
- 1.6.3-3ubuntu2
- 1.6.3-3ubuntu3
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.3-3ubuntu3.1
Обновитесь до 1.6.3-3ubuntu3.1