p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости apr-util

За последние 30 дней в apr-util опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 4

  1. CVE-2025-49506

    Высокий · CVSS 7.5EPSS 0,38%Есть исправление

    Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

    APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Обновитесь до 1.6.3-3ubuntu3.1
    Опубликовано Обновлено
  2. CVE-2026-32327

    Критический · CVSS 9.1EPSS 0,46%Есть исправление

    Apache Portable Runtime Utility: apr-util XML stack recursion crash

    A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Обновитесь до 1.6.3-3ubuntu3.1
    Опубликовано Обновлено
  3. CVE-2026-34501

    Высокий · CVSS 7.5EPSS 0,51%Есть исправление

    Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

    Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

    • Обновитесь до 1.6.3-3ubuntu3.1
    Опубликовано Обновлено
  4. CVE-2026-34502

    Высокий · CVSS 7.5EPSS 0,51%Есть исправление

    Apache Portable Runtime Utility: Heap buffer overflow in APR memcached client

    Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility memcached client This issue affects Apache Portable Runtime Utility: from 1.3.0 through 1.6.3.

    • Обновитесь до 1.6.3-3ubuntu3.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →