p PatchFirst

CVE-2026-42498

CVE-2026-42498 · Apache Tomcat: WebSocket authentication header exposure

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Exposure of HTTP Authentication Header to unexpected hosts during WebSocket authentication vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.2 through 9.0.117, from 8.5.24 through 8.5.100, from 7.0.83 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118, which fix the issue.

CVSS 7.3 · Высокий · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache tomcat

    Версии
    • ≥ 11.0.0-M1, ≤ 11.0.21: Затронуто (semver)
    • ≥ 10.1.0-M1, ≤ 10.1.54: Затронуто (semver)
    • ≥ 9.0.2, ≤ 9.0.117: Затронуто (semver)
    • ≥ 8.5.24, ≤ 8.5.100: Затронуто (semver)
    • ≥ 7.0.83, ≤ 7.0.109: Затронуто (semver)

    Нет опубликованного исправления

  • tomcat10 Debian:12

    Версии
    • 10.1.10-1
    • 10.1.13-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.20-1
    • 10.1.23-1
    • 10.1.25-1
    • 10.1.25-1~bpo12+1
    • 10.1.25-2
    • 10.1.30-1
    • 10.1.30-1~bpo12+1
    • 10.1.31-1
    • 10.1.33-1
    • 10.1.33-1~bpo12+1
    • 10.1.34-0+deb12u1
    • 10.1.34-0+deb12u2
    • 10.1.34-1
    • 10.1.35-1
    • 10.1.40-1
    • 10.1.40-1~bpo12+1
    • 10.1.46-1
    • 10.1.52-1
    • 10.1.52-1~deb12u1
    • 10.1.52-1~deb13u1
    • 10.1.52-2
    • 10.1.54-1
    • 10.1.6-1
    • 10.1.6-1+deb12u1
    • 10.1.6-1+deb12u2
    • 10.1.7-1
    • 10.1.8-1
    • 10.1.9-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.55-1~deb12u1

    Обновитесь до 10.1.55-1~deb12u1

  • tomcat10 Debian:13

    Версии
    • 10.1.40-1
    • 10.1.46-1
    • 10.1.52-1
    • 10.1.52-1~deb12u1
    • 10.1.52-1~deb13u1
    • 10.1.52-2
    • 10.1.54-1
    • 10.1.55-1~deb12u1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.55-1~deb13u1

    Обновитесь до 10.1.55-1~deb13u1

  • tomcat10 Debian:14

    Версии
    • 10.1.40-1
    • 10.1.46-1
    • 10.1.52-1
    • 10.1.52-1~deb12u1
    • 10.1.52-1~deb13u1
    • 10.1.52-2
    • 10.1.54-1
    • 10.1.55-1~deb12u1
    • 10.1.55-1~deb13u1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.55-1

    Обновитесь до 10.1.55-1

  • tomcat11 Debian:13

    Версии
    • 11.0.11-1
    • 11.0.15-1
    • 11.0.15-1~deb13u1
    • 11.0.18-1
    • 11.0.21-1
    • 11.0.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 11.0.22-1~deb13u1

    Обновитесь до 11.0.22-1~deb13u1

  • tomcat11 Debian:14

    Версии
    • 11.0.11-1
    • 11.0.15-1
    • 11.0.15-1~deb13u1
    • 11.0.18-1
    • 11.0.21-1
    • 11.0.22-1~deb13u1
    • 11.0.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 11.0.22-1

    Обновитесь до 11.0.22-1

  • tomcat9 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Ubuntu:Pro:18.04:LTS

    Версии
    • 9.0.16-3~18.04.1
    • 9.0.16-3ubuntu0.18.04.1
    • 9.0.16-3ubuntu0.18.04.2
    • 9.0.16-3ubuntu0.18.04.2+esm1
    • 9.0.16-3ubuntu0.18.04.2+esm2
    • 9.0.16-3ubuntu0.18.04.2+esm3
    • 9.0.16-3ubuntu0.18.04.2+esm4
    • 9.0.16-3ubuntu0.18.04.2+esm5
    • 9.0.16-3ubuntu0.18.04.2+esm6
    • 9.0.16-3ubuntu0.18.04.2+esm7
    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm8

    Обновитесь до 9.0.16-3ubuntu0.18.04.2+esm8

  • tomcat9 Ubuntu:Pro:20.04:LTS

    Версии
    • 9.0.24-1
    • 9.0.27-1
    • 9.0.31-1
    • 9.0.31-1ubuntu0.1
    • 9.0.31-1ubuntu0.2
    • 9.0.31-1ubuntu0.3
    • 9.0.31-1ubuntu0.4
    • 9.0.31-1ubuntu0.5
    • 9.0.31-1ubuntu0.6
    • 9.0.31-1ubuntu0.7
    • 9.0.31-1ubuntu0.8
    • 9.0.31-1ubuntu0.9
    • 9.0.31-1ubuntu0.9+esm1
    • 9.0.31-1ubuntu0.9+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.31-1ubuntu0.9+esm3

    Обновитесь до 9.0.31-1ubuntu0.9+esm3

  • tomcat9 Ubuntu:Pro:22.04:LTS

    Версии
    • 9.0.43-3
    • 9.0.54-1
    • 9.0.55-1
    • 9.0.58-1
    • 9.0.58-1ubuntu0.1
    • 9.0.58-1ubuntu0.1+esm1
    • 9.0.58-1ubuntu0.1+esm2
    • 9.0.58-1ubuntu0.1+esm3
    • 9.0.58-1ubuntu0.1+esm4
    • 9.0.58-1ubuntu0.2
    • 9.0.58-1ubuntu0.2+esm1
    • 9.0.58-1ubuntu0.2+esm2
    • 9.0.58-1ubuntu0.2+esm3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.58-1ubuntu0.2+esm4

    Обновитесь до 9.0.58-1ubuntu0.2+esm4

  • tomcat10 Ubuntu:Pro:24.04:LTS

    Версии
    • 10.1.10-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.16-1ubuntu0.1~esm1
    • 10.1.16-1ubuntu0.1~esm2
    • 10.1.16-1ubuntu0.1~esm3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm4

    Обновитесь до 10.1.16-1ubuntu0.1~esm4

  • tomcat9 Ubuntu:Pro:24.04:LTS

    Версии
    • 9.0.70-1ubuntu1
    • 9.0.70-2
    • 9.0.70-2ubuntu0.1
    • 9.0.70-2ubuntu0.1+esm1
    • 9.0.70-2ubuntu0.1+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm3

    Обновитесь до 9.0.70-2ubuntu0.1+esm3

  • tomcat10 Ubuntu:25.10

    Версии
    • 10.1.35-1
    • 10.1.40-1
    • 10.1.40-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.40-1ubuntu1.25.10.1

    Обновитесь до 10.1.40-1ubuntu1.25.10.1

  • tomcat11 Ubuntu:25.10

    Версии
    • 11.0.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • tomcat9 Ubuntu:25.10

    Версии
    • 9.0.70-2ubuntu1.1
    • 9.0.70-2ubuntu2
    • 9.0.70-2ubuntu3
    • 9.0.95-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.95-1ubuntu1.1

    Обновитесь до 9.0.95-1ubuntu1.1

  • tomcat10 Ubuntu:26.04:LTS

    Версии
    • 10.1.40-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.40-1ubuntu1.26.04.1

    Обновитесь до 10.1.40-1ubuntu1.26.04.1

  • tomcat9 Ubuntu:26.04:LTS

    Версии
    • 9.0.95-1ubuntu1
    • 9.0.111-1
    • 9.0.115-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.115-1ubuntu0.1

    Обновитесь до 9.0.115-1ubuntu0.1

  • tomcat11 Ubuntu:Pro:26.04:LTS

    Версии
    • 11.0.6-1
    • 11.0.11-1
    • 11.0.15-1
    • 11.0.18-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 11.0.18-1ubuntu0.1~esm1

    Обновитесь до 11.0.18-1ubuntu0.1~esm1

Первоисточники

Проверьте свой сервер →