p PatchFirst

CVE-2026-77634

CVE-2026-77634 · CakePHP: SmtpTransport vulnerable to CRLF header injection

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CakePHP is a rapid development framework for PHP. Prior to versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7 on their respective release lines, custom mail headers added with Message::setHeaders() or Message::addHeaders() do not have CRLF bytes removed, allowing header injection when user-controlled data is used in message headers. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7.

CVSS 8.2 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · php

Затронутые продукты и версии

  • cakephp

    Версии
    • >= 4.5.0, < 4.5.12: Затронуто
    • >= 4.6.0, < 4.6.5: Затронуто
    • >= 5.0.0, < 5.1.9: Затронуто
    • >= 5.2.0, < 5.2.14: Затронуто
    • >= 5.3.0, < 5.3.7: Затронуто

    Нет опубликованного исправления

  • cakephp Debian:11

    Версии
    • 2.10.11-2.1
    • 2.10.24-1
    • 2.10.24-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp/cakephp Packagist

    Версии
    • 4.5.0
    • 4.5.1
    • 4.5.10
    • 4.5.11
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.5.6
    • 4.5.7
    • 4.5.8
    • 4.5.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.5.0, < 4.5.12

    Обновитесь до 4.5.12

  • cakephp/cakephp Packagist

    Версии
    • 4.6.0
    • 4.6.1
    • 4.6.2
    • 4.6.3
    • 4.6.4
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.6.0, < 4.6.5

    Обновитесь до 4.6.5

  • cakephp/cakephp Packagist

    Версии
    • 5.0.0
    • 5.0.1
    • 5.0.10
    • 5.0.11
    • 5.0.2
    • 5.0.3
    • 5.0.4
    • 5.0.5
    • 5.0.6
    • 5.0.7
    • 5.0.8
    • 5.0.9
    • 5.1.0
    • 5.1.0-RC1
    • 5.1.0-RC2
    • 5.1.1
    • 5.1.2
    • 5.1.4
    • 5.1.5
    • 5.1.6
    • 5.1.7
    • 5.1.8
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.0.0, < 5.1.9

    Обновитесь до 5.1.9

  • cakephp/cakephp Packagist

    Версии
    • 5.2.0
    • 5.2.1
    • 5.2.10
    • 5.2.11
    • 5.2.12
    • 5.2.13
    • 5.2.2
    • 5.2.3
    • 5.2.4
    • 5.2.5
    • 5.2.6
    • 5.2.7
    • 5.2.8
    • 5.2.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.2.0, < 5.2.14

    Обновитесь до 5.2.14

  • cakephp/cakephp Packagist

    Версии
    • 5.3.0
    • 5.3.1
    • 5.3.2
    • 5.3.3
    • 5.3.4
    • 5.3.5
    • 5.3.6
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.3.0, < 5.3.7

    Обновитесь до 5.3.7

  • cakephp Ubuntu:16.04:LTS

    Версии
    • 2.7.2-1
    • 2.8.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp Ubuntu:20.04:LTS

    Версии
    • 2.10.11-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp Ubuntu:22.04:LTS

    Версии
    • 2.10.11-2.1
    • 2.10.24-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →