p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости cakephp

За последние 30 дней в cakephp опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 10

  1. CVE-2026-77337

    Критический · CVSS 9.1EPSS 0,7%Нет опубликованного исправления

    CakePHP: Potential Authentication bypass with CookieAuthenticator

    CakePHP Authentication is an authentication plugin for CakePHP that can also be used in PSR-7 based applications. Versions before 2.11.2, from 3.0.0 through 3.3.6, and from 4.0.0 through 4.2.0 allow authentication bypass and potential CPU or memory exhaustion when CookieAuthenticator uses unencrypted, forgeable legacy tokens. This issue is fixed in versions 2.11.2, 3.3.7, and 4.2.1.

    Опубликовано Обновлено
  2. CVE-2026-77634

    Высокий · CVSS 8.2EPSS 0,54%Нет опубликованного исправления

    CakePHP: SmtpTransport vulnerable to CRLF header injection

    CakePHP is a rapid development framework for PHP. Prior to versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7 on their respective release lines, custom mail headers added with Message::setHeaders() or Message::addHeaders() do not have CRLF bytes removed, allowing header injection when user-controlled data is used in message headers. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7.

    Опубликовано Обновлено
  3. CVE-2026-77635

    Критический · CVSS 9.2EPSS 0,49%Публичный эксплойтНет опубликованного исправления

    CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

    CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.

    Опубликовано Обновлено
  4. CVE-2026-48820

    Средний · CVSS 6.3EPSS 0,26%Нет опубликованного исправления

    CakePHP: View::element() is missing a path containment check

    CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the application/plugin view template paths. When element names are created with specifically crafted user-supplied data this weakness can be leveraged to include other PHP files on the server. Patched releases are available in 5.3.6, 5.2.13, 5.1.7, 4.6.4, and 4.5.11.

    Опубликовано Обновлено
  5. CVE-2016-4793

    Высокий · CVSS 7.5EPSS 5,15%Публичный эксплойтЕсть исправление

    CVE-2016-4793

    The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.

    • Обновитесь до 2.8.3-1
    Опубликовано Обновлено
  6. CVE-2015-8379

    Высокий · CVSS 8.8EPSS 1,4%Есть исправление

    CVE-2015-8379

    CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF protection mechanism via the _method parameter.

    • Обновитесь до 2.8.0-1
    Опубликовано Обновлено
  7. CVE-2010-4335

    Без оценкиEPSS 55,2%Публичный эксплойтЕсть исправление

    CVE-2010-4335

    The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to modify the internal Cake cache and execute arbitrary code via a crafted data[_Token][fields] value that is processed by the unserialize function, as demonstrated by modifying the file_map cache to execute arbitrary local files.

    • Обновитесь до 1.3.2-1.1
    Опубликовано Обновлено
  8. CVE-2006-5031

    Без оценкиEPSS 7,67%Публичный эксплойтЕсть исправление

    CVE-2006-5031

    Directory traversal vulnerability in app/webroot/js/vendors.php in Cake Software Foundation CakePHP before 1.1.8.3544 allows remote attackers to read arbitrary files via a .. (dot dot) in the file parameter, followed by a filename ending with "%00" and a .js filename.

    • Обновитесь до 1.1.13.4450-1
    Опубликовано Обновлено
  9. CVE-2006-4067

    Средний · CVSS 6.5EPSS 1,21%Есть исправление

    CVE-2006-4067

    Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 ("Not Found") error page. NOTE: some of these details are obtained from third party information.

    • Обновитесь до 1.1.13.4450-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →