p PatchFirst

CVE-2026-77635

CVE-2026-77635 · CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.

CVSS 9.2 · Критический · EPSS 0,5% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: system · php

Затронутые продукты и версии

  • cakephp

    Версии
    • >= 5.1.0, < 5.1.10: Затронуто
    • >= 5.2.0, < 5.2.15: Затронуто
    • >= 5.3.0, < 5.3.7: Затронуто

    Нет опубликованного исправления

  • cakephp/database

    Версии
    • >= 5.1.0, < 5.1.10: Затронуто
    • >= 5.2.0, < 5.2.15: Затронуто
    • >= 5.3.0, < 5.3.7: Затронуто

    Нет опубликованного исправления

  • cakephp Debian:11

    Версии
    • 2.10.11-2.1
    • 2.10.24-1
    • 2.10.24-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp/cakephp Packagist

    Версии
    • 5.3.0
    • 5.3.1
    • 5.3.2
    • 5.3.3
    • 5.3.4
    • 5.3.5
    • 5.3.6
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.3.0, < 5.3.7

    Обновитесь до 5.3.7

  • cakephp/cakephp Packagist

    Версии
    • 5.2.0
    • 5.2.1
    • 5.2.10
    • 5.2.11
    • 5.2.12
    • 5.2.13
    • 5.2.14
    • 5.2.2
    • 5.2.3
    • 5.2.4
    • 5.2.5
    • 5.2.6
    • 5.2.7
    • 5.2.8
    • 5.2.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.2.0, < 5.2.15

    Обновитесь до 5.2.15

  • cakephp/cakephp Packagist

    Версии
    • 5.1.0
    • 5.1.1
    • 5.1.2
    • 5.1.4
    • 5.1.5
    • 5.1.6
    • 5.1.7
    • 5.1.8
    • 5.1.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.1.0, < 5.1.10

    Обновитесь до 5.1.10

  • cakephp/database Packagist

    Версии
    • 5.3.0
    • 5.3.2
    • 5.3.3
    • 5.3.4
    • 5.3.5
    • 5.3.6
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.3.0, < 5.3.7

    Обновитесь до 5.3.7

  • cakephp/database Packagist

    Версии
    • 5.2.0
    • 5.2.1
    • 5.2.10
    • 5.2.11
    • 5.2.12
    • 5.2.13
    • 5.2.14
    • 5.2.2
    • 5.2.3
    • 5.2.4
    • 5.2.5
    • 5.2.6
    • 5.2.7
    • 5.2.8
    • 5.2.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.2.0, < 5.2.15

    Обновитесь до 5.2.15

  • cakephp/database Packagist

    Версии
    • 5.1.0
    • 5.1.1
    • 5.1.2
    • 5.1.4
    • 5.1.5
    • 5.1.6
    • 5.1.8
    • 5.1.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.1.0, < 5.1.10

    Обновитесь до 5.1.10

  • cakephp Ubuntu:16.04:LTS

    Версии
    • 2.7.2-1
    • 2.8.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp Ubuntu:20.04:LTS

    Версии
    • 2.10.11-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp Ubuntu:22.04:LTS

    Версии
    • 2.10.11-2.1
    • 2.10.24-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →