CVE-2026-86247
CVE-2026-86247 · Apache Tomcat Native: Client certificate requirements can be down-graded
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
CVSS 7.4 · Высокий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache tomcat native
- Версии
- ≥ 2.0.0, ≤ 2.0.15: Затронуто (semver)
- ≥ 1.3.0, ≤ 1.3.8: Затронуто (semver)
Нет опубликованного исправления
tomcat-native Debian:12
- Версии
- 1.2.35-1
- 1.3.1-1
- 1.3.7-1
- 2.0.14-1
- 2.0.16-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Debian:13
- Версии
- 1.3.1-1
- 1.3.7-1
- 2.0.14-1
- 2.0.16-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Debian:14
- Версии
- 1.3.1-1
- 1.3.7-1
- 2.0.14-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.16-1
Обновитесь до 2.0.16-1
tomcat-native Ubuntu:16.04:LTS
- Версии
- 1.1.33-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Ubuntu:18.04:LTS
- Версии
- 1.2.14-1
- 1.2.16-1
- 1.2.16-1build1
- 1.2.21-1~18.04.1
- 1.2.21-1~18.04.1build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Ubuntu:20.04:LTS
- Версии
- 1.2.23-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Ubuntu:22.04:LTS
- Версии
- 1.2.26-1
- 1.2.31-1
- 1.2.31-1build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Ubuntu:24.04:LTS
- Версии
- 1.2.35-1
- 1.2.35-1build1
- 1.2.35-1build2
- 2.0.14-1~24.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Ubuntu:26.10
- Версии
- 1.3.1-1build1
- 2.0.14-1
- 2.0.15~us1-0ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat-native Ubuntu:26.04:LTS
- Версии
- 1.3.1-1
- 1.3.1-1build1
- 2.0.14-1~26.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления