p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости tomcat-native

За последние 30 дней в tomcat-native опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 6

  1. CVE-2026-86247

    Высокий · CVSS 7.4EPSS 0,2%Нет опубликованного исправления

    Apache Tomcat Native: Client certificate requirements can be down-graded

    Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.

    Опубликовано Обновлено
  2. CVE-2026-86246

    Критический · CVSS 9.1EPSS 0,35%Нет опубликованного исправления

    Apache Tomcat Native: Insecure OpenSSL options enabled

    Initialization of a resource with an insecure default vulnerability in Apache Tomcat Native enabled insecure options by default including ALLOW_CLIENT_RENEGOTIATION, NO_EXTENDED_MASTER_SECRET, IGNORE_UNEXPECTED_EOF and ALLOW_NO_DHE_KEX. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fix the issue.

    Опубликовано Обновлено
  3. CVE-2026-86243

    Высокий · CVSS 7.5EPSS 0,56%Нет опубликованного исправления

    Apache Tomcat Native: DoS via TLS handshake

    Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.

    Опубликовано Обновлено
  4. CVE-2018-8020

    Высокий · CVSS 7.4EPSS 4,18%Нет опубликованного исправления

    CVE-2018-8020

    Apache Tomcat Native 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 has a flaw that does not properly check OCSP pre-produced responses, which are lists (multiple entries) of certificate statuses. Subsequently, revoked client certificates may not be properly identified, allowing for users to authenticate with revoked certificates to connections that require mutual TLS. Users not using OCSP checks are not affected by this vulnerability.

    Опубликовано Обновлено
  5. CVE-2018-8019

    Высокий · CVSS 7.4EPSS 4,05%Нет опубликованного исправления

    CVE-2018-8019

    When using an OCSP responder Apache Tomcat Native 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 did not correctly handle invalid responses. This allowed for revoked client certificates to be incorrectly identified. It was therefore possible for users to authenticate with revoked certificates when using mutual TLS. Users not using OCSP checks are not affected by this vulnerability.

    Опубликовано Обновлено
  6. CVE-2017-15698

    Средний · CVSS 5.9EPSS 3,53%Нет опубликованного исправления

    CVE-2017-15698

    When parsing the AIA-Extension field of a client certificate, Apache Tomcat Native Connector 1.2.0 to 1.2.14 and 1.1.23 to 1.1.34 did not correctly handle fields longer than 127 bytes. The result of the parsing error was to skip the OCSP check. It was therefore possible for client certificates that should have been rejected (if the OCSP check had been made) to be accepted. Users not using OCSP checks are not affected by this vulnerability.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →