p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости dnsmasq

За последние 30 дней в dnsmasq опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 46

  1. CVE-2026-13002

    Средний · CVSS 4.4EPSS 0,15%Нет опубликованного исправления

    Dnsmasq: infinite loop dos in dnssec nsec/nsec3 type bitmap parsing

    A flow has been identified into dnssec.c library, causing an infinite loop to dnsmasq service. An attacker who controls any DNSSEC-signed zone can hang the dnsmasq process with a single crafted response, killing all DNS resolution for its clients.

    Опубликовано Обновлено
  2. CVE-2026-12969

    Средний · CVSS 5.3EPSS 0,26%Нет опубликованного исправления

    Dnsmasq: dnsmasq: out-of-bounds read in find_soa() due to missing extrabytes validation

    An out-of-bounds read vulnerability exists in dnsmasq's find_soa() function in src/rfc1035.c. When parsing NS section records, extract_name() is called with extrabytes=0, failing to validate that 10 additional bytes exist for fixed-length DNS record fields. A remote attacker controlling a DNS zone can exploit this via a crafted NXDOMAIN response to cause a 10-byte heap out-of-bounds read, potentially accessing stale data from prior transactions.

    Опубликовано Обновлено
  3. CVE-2026-12725

    Средний · CVSS 5.9EPSS 0,53%Нет опубликованного исправления

    Dnsmasq: dnsmasq: heap buffer overflow in log_query() when logging unsupported ds/dnskey replies

    A heap-based buffer overflow was found in dnsmasq. When DNSSEC validation and query logging are both enabled, logging of DS or DNSKEY replies containing unsupported algorithm or digest types can cause dnsmasq to write past the end of an internal logging buffer. A remote attacker able to supply such a DNS response may crash the dnsmasq process, resulting in denial of service.

    Опубликовано Обновлено
  4. CVE-2026-5172

    Высокий · CVSS 7.3EPSS 2,68%Есть исправление

    CVE-2026-5172

    A buffer overflow in dnsmasq’s extract_addresses() function allows an attacker to trigger a heap out-of-bounds read and crash by exploiting a malformed DNS response, enabling extract_name() to advance the pointer past the record’s end.

    • Обновитесь до 2.90-4~deb12u2
  5. CVE-2026-4893

    Средний · CVSS 5.3EPSS 1,78%Есть исправление

    CVE-2026-4893

    An information disclosure vulnerability in dnsmasq allows remote attackers to bypass source checks via a crafted DNS packet with RFC 7871 client subnet information.

    • Обновитесь до 2.90-4~deb12u2
  6. CVE-2026-4892

    Высокий · CVSS 8.4EPSS 0,81%Есть исправление

    CVE-2026-4892

    A heap-based out-of-bounds write vulnerability in the DHCPv6 implementation of dnsmasq allows local attackers to execute arbitrary code with root privileges via a crafted DHCPv6 packet.

    • Обновитесь до 2.90-4~deb12u2
  7. CVE-2026-4891

    Средний · CVSS 5.3EPSS 6,41%Есть исправление

    CVE-2026-4891

    A heap-based out-of-bounds read vulnerability in the DNSSEC validation of dnsmasq allows remote attackers to cause a denial of service via a crafted DNS packet.

    • Обновитесь до 2.90-4~deb12u2
  8. CVE-2026-4890

    Высокий · CVSS 7.5EPSS 8,85%Есть исправление

    CVE-2026-4890

    A Denial of Service (DoS) vulnerability in the DNSSEC validation of dnsmasq allows remote attackers to cause a denial of service via a crafted DNS packet.

    • Обновитесь до 2.90-4~deb12u2
  9. CVE-2026-2291

    Высокий · CVSS 7.3EPSS 0,61%Публичный эксплойтЕсть исправление

    CVE-2026-2291

    dnsmasqs extract_name() function can be abused to cause a heap buffer overflow, allowing an attacker to inject false DNS cache entries, which could result in DNS lookups to redirect to an attacker-controlled IP address, or to cause a DoS.

    • Обновитесь до 2.90-4~deb12u2
  10. CVE-2020-37127

    Средний · CVSS 6.9EPSS 0,21%Есть исправление

    dnsmasq-utils 2.79-1 - 'dhcp_release' Denial of Service

    Dnsmasq-utils 2.79-1 contains a buffer overflow vulnerability in the dhcp_release utility that allows attackers to cause a denial of service by supplying excessive input. Attackers can trigger a core dump and terminate the dhcp_release process by sending a crafted input string longer than 16 characters.

    • Обновитесь до 2.80-1
    Опубликовано Обновлено
  11. CVE-2023-50868

    Высокий · CVSS 7.5EPSS 74,3%Есть исправление

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 2.90-4~deb12u1
    Опубликовано Обновлено
  12. CVE-2023-50387

    Высокий · CVSS 7.5EPSS 99,99%Есть исправление

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 2.90-4~deb12u1
    Опубликовано Обновлено
  13. CVE-2023-28450

    Высокий · CVSS 7.5EPSS 1,84%Есть исправление

    CVE-2023-28450

    An issue was discovered in Dnsmasq before 2.90. The default maximum EDNS.0 UDP packet size was set to 4096 but should be 1232 because of DNS Flag Day 2020.

    • Обновитесь до 2.90-4~deb12u1
  14. CVE-2022-0934

    Высокий · CVSS 7.5EPSS 2,64%Есть исправление

    CVE-2022-0934

    A single-byte, non-arbitrary write/use-after-free flaw was found in dnsmasq. This flaw allows an attacker who sends a crafted packet processed by dnsmasq, potentially causing a denial of service.

    • Обновитесь до 2.87-1
    Опубликовано Обновлено
  15. CVE-2021-3448

    Средний · CVSS 4EPSS 2,28%Есть исправление

    CVE-2021-3448

    A flaw was found in dnsmasq in versions before 2.85. When configured to use a specific server for a given network interface, dnsmasq uses a fixed port while forwarding queries. An attacker on the network, able to find the outgoing port used by dnsmasq, only needs to guess the random transmission ID to forge a reply and get it accepted by dnsmasq. This flaw makes a DNS Cache Poisoning attack much easier. The highest threat from this vulnerability is to data integrity.

    • Обновитесь до 2.85-1
    Опубликовано Обновлено
  16. CVE-2020-14312

    Средний · CVSS 5.9EPSS 1,23%Есть исправление

    CVE-2020-14312

    A flaw was found in the default configuration of dnsmasq, as shipped with Fedora versions prior to 31 and in all versions Red Hat Enterprise Linux, where it listens on any interface and accepts queries from addresses outside of its local subnet. In particular, the option `local-service` is not enabled. Running dnsmasq in this manner may inadvertently make it an open resolver accessible from any address on the internet. This flaw allows an attacker to conduct a Distributed Denial of Service (DDoS) against other systems.

    • Обновитесь до 2.69-1
    Опубликовано Обновлено
  17. CVE-2020-25686

    Низкий · CVSS 3.7EPSS 5,47%Есть исправление

    CVE-2020-25686

    A flaw was found in dnsmasq before version 2.83. When receiving a query, dnsmasq does not check for an existing pending request for the same name and forwards a new request. By default, a maximum of 150 pending queries can be sent to upstream servers, so there can be at most 150 queries for the same name. This flaw allows an off-path attacker on the network to substantially reduce the number of attempts that it would have to perform to forge a reply and have it accepted by dnsmasq. This issue is mentioned in the "Birthday Attacks" section of RFC5452. If chained with CVE-2020-25684, the attack complexity of a successful attack is reduced. The

    • Обновитесь до 2.83-1
    Опубликовано Обновлено
  18. CVE-2020-25681

    Высокий · CVSS 8.1EPSS 84,08%Есть исправление

    CVE-2020-25681

    A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in the way RRSets are sorted before validating with DNSSEC data. An attacker on the network, who can forge DNS replies such as that they are accepted as valid, could use this flaw to cause a buffer overflow with arbitrary data in a heap memory segment, possibly executing code on the machine. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Обновитесь до 2.83-1
    Опубликовано Обновлено
  19. CVE-2020-25687

    Средний · CVSS 5.9EPSS 89,28%Есть исправление

    CVE-2020-25687

    A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in dnsmasq when DNSSEC is enabled and before it validates the received DNS entries. This flaw allows a remote attacker, who can create valid DNS replies, to cause an overflow in a heap-allocated memory. This flaw is caused by the lack of length checks in rfc1035.c:extract_name(), which could be abused to make the code execute memcpy() with a negative size in sort_rrset() and cause a crash in dnsmasq, resulting in a denial of service. The highest threat from this vulnerability is to system availability.

    • Обновитесь до 2.83-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →