p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости libvpx

За последние 30 дней в libvpx опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 31

  1. CVE-2026-2447

    Высокий · CVSS 8.8EPSS 0,7%Есть исправление

    Heap buffer overflow in libvpx

    Heap buffer overflow in libvpx. This vulnerability was fixed in Firefox 147.0.4, Firefox ESR 140.7.1, Firefox ESR 115.32.1, Thunderbird 140.7.2, and Thunderbird 147.0.2.

    • Обновитесь до 1.12.0-1+deb12u5
    Опубликовано Обновлено
  2. CVE-2025-5283

    Средний · CVSS 5.4EPSS 0,64%Есть исправление

    CVE-2025-5283

    Use after free in libvpx in Google Chrome prior to 137.0.7151.55 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Medium)

    • Обновитесь до 1.12.0-1+deb12u4
  3. CVE-2024-5197

    Средний · CVSS 5.9EPSS 0,81%Есть исправление

    Integer overflow in libvpx

    There exists interger overflows in libvpx in versions prior to 1.14.1. Calling vpx_img_alloc() with a large value of the d_w, d_h, or align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. Calling vpx_img_wrap() with a large value of the d_w, d_h, or stride_align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. We recommend upgrading to version 1.14.1 or beyond

    • Обновитесь до 1.12.0-1+deb12u3
  4. CVE-2023-6349

    Средний · CVSS 5.7EPSS 0,36%Есть исправление

    Heap overflow in libvpx

    A heap overflow vulnerability exists in libvpx - Encoding a frame that has larger dimensions than the originally configured size with VP9 may result in a heap overflow in libvpx. We recommend upgrading to version 1.13.1 or above

    • Обновитесь до 1.12.0-1+deb12u2
    Опубликовано Обновлено
  5. CVE-2023-5217

    Высокий · CVSS 8.8EPSS 49,01%В каталоге KEVЕсть исправление

    CVE-2023-5217

    Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

    • Обновитесь до 1.12.0-1+deb12u1
    Опубликовано Обновлено
  6. CVE-2020-0034

    Высокий · CVSS 7.5EPSS 1,94%Есть исправление

    CVE-2020-0034

    In vp8_decode_frame of decodeframe.c, there is a possible out of bounds read due to improper input validation. This could lead to remote information disclosure if error correction were turned on, with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.0 Android-8.1Android ID: A-62458770

    • Обновитесь до 1.7.0-3
    Опубликовано Обновлено
  7. CVE-2019-9433

    Средний · CVSS 6.5EPSS 3,12%Есть исправление

    CVE-2019-9433

    In libvpx, there is a possible information disclosure due to improper input validation. This could lead to remote information disclosure with no additional execution privileges needed. User interaction is needed for exploitation. Product: AndroidVersions: Android-10Android ID: A-80479354

    • Обновитесь до 1.8.1-2
    Опубликовано Обновлено
  8. CVE-2019-9371

    Средний · CVSS 6.5EPSS 3,14%Есть исправление

    CVE-2019-9371

    In libvpx, there is a possible resource exhaustion due to improper input validation. This could lead to remote denial of service with no additional execution privileges needed. User interaction is needed for exploitation. Product: AndroidVersions: Android-10Android ID: A-132783254

    • Обновитесь до 1.8.1-2
    Опубликовано Обновлено
  9. CVE-2019-9325

    Средний · CVSS 6.5EPSS 2,57%Есть исправление

    CVE-2019-9325

    In libvpx, there is a possible out of bounds read due to a missing bounds check. This could lead to remote information disclosure with no additional execution privileges needed. User interaction is needed for exploitation. Product: AndroidVersions: Android-10Android ID: A-112001302

    • Обновитесь до 1.8.1-2
    Опубликовано Обновлено
  10. CVE-2019-9232

    Высокий · CVSS 7.5EPSS 5,08%Есть исправление

    CVE-2019-9232

    In libvpx, there is a possible out of bounds read due to a missing bounds check. This could lead to remote information disclosure with no additional execution privileges needed. User interaction is not needed for exploitation. Product: AndroidVersions: Android-10Android ID: A-122675483

    • Обновитесь до 1.8.1-2
    Опубликовано Обновлено
  11. CVE-2017-13194

    Высокий · CVSS 7.5EPSS 1,8%Есть исправление

    CVE-2017-13194

    A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.

    • Обновитесь до 1.7.0-2
    Опубликовано Обновлено
  12. CVE-2017-0393

    Средний · CVSS 5.5EPSS 0,89%Есть исправление

    CVE-2017-0393

    A denial of service vulnerability in libvpx in Mediaserver could enable a remote attacker to use a specially crafted file to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service. Product: Android. Versions: 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1. Android ID: A-30436808.

    • Обновитесь до 1.6.1-1
    Опубликовано Обновлено
  13. CVE-2016-6712

    Средний · CVSS 5.5EPSS 0,72%Есть исправление

    CVE-2016-6712

    A remote denial of service vulnerability in libvpx in Mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, and 6.x before 2016-11-01 could enable an attacker to use a specially crafted file to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service. Android ID: A-30593752.

    • Обновитесь до 1.6.1-1
    Опубликовано Обновлено
  14. CVE-2016-6711

    Средний · CVSS 5.5EPSS 0,68%Есть исправление

    CVE-2016-6711

    A remote denial of service vulnerability in libvpx in Mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, and 6.x before 2016-11-01 could enable an attacker to use a specially crafted file to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service. Android ID: A-30593765.

    • Обновитесь до 1.6.1-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →