p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости node-marked

За последние 30 дней в node-marked опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 9

  1. CVE-2018-25110

    Средний · CVSS 6.9EPSS 0,61%Есть исправление

    Regular Expression Denial of Service (ReDoS) in markedjs/marked

    Marked prior to version 0.3.17 is vulnerable to a Regular Expression Denial of Service (ReDoS) attack due to catastrophic backtracking in several regular expressions used for parsing HTML tags and markdown links. An attacker can exploit this vulnerability by providing specially crafted markdown input, such as deeply nested or repetitively structured brackets or tag attributes, which cause the parser to hang and lead to a Denial of Service.

    • Обновитесь до 0.5.1+dfsg-1
  2. CVE-2022-21681

    Высокий · CVSS 7.5EPSS 2,77%Есть исправление

    Exponential catastrophic backtracking (ReDoS) in marked

    Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `inline.reflinkSearch` may cause catastrophic backtracking against some strings and lead to a denial of service (DoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.

    • Обновитесь до 4.0.12+ds+~4.0.1-1
    Опубликовано Обновлено
  3. CVE-2022-21680

    Высокий · CVSS 7.5EPSS 2,85%Есть исправление

    Cubic catastrophic backtracking (ReDoS) in marked

    Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `block.def` may cause catastrophic backtracking against some strings and lead to a regular expression denial of service (ReDoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.

    • Обновитесь до 4.0.12+ds+~4.0.1-1
    Опубликовано Обновлено
  4. CVE-2014-3743

    Средний · CVSS 6.1EPSS 1,71%Есть исправление

    CVE-2014-3743

    Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.

    • Обновитесь до 0.3.1+dfsg-1
    Опубликовано Обновлено
  5. CVE-2017-16114

    Высокий · CVSS 7.5EPSS 1,73%Есть исправление

    CVE-2017-16114

    The marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.

    • Обновитесь до 0.3.9+dfsg-1
    Опубликовано Обновлено
  6. CVE-2016-10531

    Средний · CVSS 6.1EPSS 1,44%Есть исправление

    CVE-2016-10531

    marked is an application that is meant to parse and compile markdown. Due to the way that marked 0.3.5 and earlier parses input, specifically HTML entities, it's possible to bypass marked's content injection protection (`sanitize: true`) to inject a `javascript:` URL. This flaw exists because `&#xNNanything;` gets parsed to what it could and leaves the rest behind, resulting in just `anything;` being left.

    • Обновитесь до 0.3.6+dfsg-1
    Опубликовано Обновлено
  7. CVE-2015-8854

    Высокий · CVSS 7.5EPSS 4,42%Есть исправление

    CVE-2015-8854

    The marked package before 0.3.4 for Node.js allows attackers to cause a denial of service (CPU consumption) via unspecified vectors that trigger a "catastrophic backtracking issue for the em inline rule," aka a "regular expression denial of service (ReDoS)."

    • Обновитесь до 0.3.6+dfsg-1
    Опубликовано Обновлено
  8. CVE-2015-1370

    Без оценкиEPSS 2,04%Есть исправление

    CVE-2015-1370

    Incomplete blacklist vulnerability in marked 0.3.2 and earlier for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks via a vbscript tag in a link.

    • Обновитесь до 0.3.6+dfsg-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →