p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости dnsjava

За последние 30 дней в dnsjava опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 3

  1. CVE-2024-25638

    Высокий · CVSS 8.9EPSS 0,39%Есть исправление

    DNSJava DNSSEC Bypass

    dnsjava is an implementation of DNS in Java. Records in DNS replies are not checked for their relevance to the query, allowing an attacker to respond with RRs from different zones. This vulnerability is fixed in 3.6.0.

    • Обновитесь до 3.6.2-1
  2. CVE-2023-50868

    Высокий · CVSS 7.5EPSS 74,3%Есть исправление

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 3.6.2-1
    Опубликовано Обновлено
  3. CVE-2023-50387

    Высокий · CVSS 7.5EPSS 99,99%Есть исправление

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 3.6.2-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →