p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости openvpn · Страница 2

За последние 30 дней в openvpn опубликовано уязвимостей: 3; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 40

  1. CVE-2022-0547

    Критический · CVSS 9.8EPSS 3,57%Есть исправление

    CVE-2022-0547

    OpenVPN 2.1 until v2.4.12 and v2.5.6 may enable authentication bypass in external authentication plug-ins when more than one of them makes use of deferred authentication replies, which allows an external user to be granted access with only partially correct credentials.

    • Обновитесь до 2.5.6-1
  2. CVE-2020-15078

    Высокий · CVSS 7.5EPSS 4,91%Есть исправление

    CVE-2020-15078

    OpenVPN 2.5.1 and earlier versions allows a remote attackers to bypass authentication and access control channel data on servers configured with deferred authentication, which can be used to potentially trigger further information leaks.

    • Обновитесь до 2.5.1-2
    Опубликовано Обновлено
  3. CVE-2020-11810

    Низкий · CVSS 3.7EPSS 1,65%Есть исправление

    CVE-2020-11810

    An issue was discovered in OpenVPN 2.4.x before 2.4.9. An attacker can inject a data channel v2 (P_DATA_V2) packet using a victim's peer-id. Normally such packets are dropped, but if this packet arrives before the data channel crypto parameters have been initialized, the victim's connection will be dropped. This requires careful timing due to the small time window (usually within a few seconds) between the victim client connection starting and the server PUSH_REPLY response back to the client. This attack will only work if Negotiable Cipher Parameters (NCP) is in use.

    • Обновитесь до 2.4.9-1
    Опубликовано Обновлено
  4. CVE-2017-12166

    Критический · CVSS 9.8EPSS 3,63%Есть исправление

    CVE-2017-12166

    OpenVPN versions before 2.3.3 and 2.4.x before 2.4.4 are vulnerable to a buffer overflow vulnerability when key-method 1 is used, possibly resulting in code execution.

    • Обновитесь до 2.4.4-1
    Опубликовано Обновлено
  5. CVE-2017-7522

    Средний · CVSS 6.5EPSS 5,54%Есть исправление

    CVE-2017-7522

    OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

    • Обновитесь до 2.4.3-1
  6. CVE-2017-7521

    Средний · CVSS 5.9EPSS 3,85%Есть исправление

    CVE-2017-7521

    OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote denial-of-service due to memory exhaustion caused by memory leaks and double-free issue in extract_x509_extension().

    • Обновитесь до 2.4.3-1
  7. CVE-2017-7520

    Высокий · CVSS 7.4EPSS 3,38%Есть исправление

    CVE-2017-7520

    OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service and/or possibly sensitive memory leak triggered by man-in-the-middle attacker.

    • Обновитесь до 2.4.3-1
  8. CVE-2017-7508

    Высокий · CVSS 7.5EPSS 4,76%Есть исправление

    CVE-2017-7508

    OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote denial-of-service when receiving malformed IPv6 packet.

    • Обновитесь до 2.4.3-1
  9. CVE-2017-7479

    Средний · CVSS 6.5EPSS 1,85%Есть исправление

    CVE-2017-7479

    OpenVPN versions before 2.3.15 and before 2.4.2 are vulnerable to reachable assertion when packet-ID counter rolls over resulting into Denial of Service of server by authenticated attacker.

    • Обновитесь до 2.4.0-5
  10. CVE-2017-7478

    Высокий · CVSS 7.5EPSS 13,78%Публичный эксплойтЕсть исправление

    CVE-2017-7478

    OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.

    • Обновитесь до 2.4.0-5
  11. CVE-2014-8104

    Без оценкиEPSS 3,48%Есть исправление

    CVE-2014-8104

    OpenVPN 2.x before 2.0.11, 2.1.x, 2.2.x before 2.2.3, and 2.3.x before 2.3.6 allows remote authenticated users to cause a denial of service (server crash) via a small control channel packet.

    • Обновитесь до 2.3.4-5
    Опубликовано Обновлено
  12. CVE-2013-2061

    Без оценкиEPSS 2,81%Есть исправление

    CVE-2013-2061

    The openvpn_decrypt function in crypto.c in OpenVPN 2.3.0 and earlier, when running in UDP mode, allows remote attackers to obtain sensitive information via a timing attack involving an HMAC comparison function that does not run in constant time and a padding oracle attack on the CBC mode cipher.

    • Обновитесь до 2.3.1-1
    Опубликовано Обновлено
  13. CVE-2008-3459

    Без оценкиEPSS 2,12%Есть исправление

    CVE-2008-3459

    Unspecified vulnerability in OpenVPN 2.1-beta14 through 2.1-rc8, when running on non-Windows systems, allows remote servers to execute arbitrary commands via crafted (1) lladdr and (2) iproute configuration directives, probably related to shell metacharacters.

    • Обновитесь до 2.1~rc9-1
    Опубликовано Обновлено
  14. CVE-2006-1629

    Без оценкиEPSS 3,09%Есть исправление

    CVE-2006-1629

    OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

    • Обновитесь до 2.0.6-1
    Опубликовано Обновлено
  15. CVE-2005-3409

    Без оценкиEPSS 2,5%Есть исправление

    CVE-2005-3409

    OpenVPN 2.x before 2.0.4, when running in TCP mode, allows remote attackers to cause a denial of service (segmentation fault) by forcing the accept function call to return an error status, which leads to a null dereference in an exception handler.

    • Обновитесь до 2.0.5-1
    Опубликовано Обновлено
  16. CVE-2005-3393

    Без оценкиEPSS 3,48%Есть исправление

    CVE-2005-3393

    Format string vulnerability in the foreign_option function in options.c for OpenVPN 2.0.x allows remote clients to execute arbitrary code via format string specifiers in a push of the dhcp-option command option.

    • Обновитесь до 2.0.5-1
    Опубликовано Обновлено
  17. CVE-2005-2534

    Без оценкиEPSS 0,97%Есть исправление

    CVE-2005-2534

    Race condition in OpenVPN before 2.0.1, when --duplicate-cn is not enabled, allows remote attackers to cause a denial of service (server crash) via simultaneous TCP connections from multiple clients that use the same client certificate.

    • Обновитесь до 2.0.2-1
    Опубликовано Обновлено
  18. CVE-2005-2533

    Без оценкиEPSS 0,68%Есть исправление

    CVE-2005-2533

    OpenVPN before 2.0.1, when running in "dev tap" Ethernet bridging mode, allows remote authenticated clients to cause a denial of service (memory exhaustion) via a flood of packets with a large number of spoofed MAC addresses.

    • Обновитесь до 2.0.2-1
    Опубликовано Обновлено
  19. CVE-2005-2532

    Без оценкиEPSS 2,74%Есть исправление

    CVE-2005-2532

    OpenVPN before 2.0.1 does not properly flush the OpenSSL error queue when a packet can not be decrypted by the server, which allows remote authenticated attackers to cause a denial of service (client disconnection) via a large number of packets that can not be decrypted.

    • Обновитесь до 2.0.2-1
    Опубликовано Обновлено
  20. CVE-2005-2531

    Без оценкиEPSS 1,97%Есть исправление

    CVE-2005-2531

    OpenVPN before 2.0.1, when running with "verb 0" and without TLS authentication, does not properly flush the OpenSSL error queue when a client fails certificate authentication to the server and causes the error to be processed by the wrong client, which allows remote attackers to cause a denial of service (client disconnection) via a large number of failed authentication attempts.

    • Обновитесь до 2.0.2-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →