p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости wordpress · Страница 4

За последние 30 дней в wordpress опубликовано уязвимостей: 1; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 352

  1. CVE-2019-16781

    Средний · CVSS 5.8EPSS 1,61%Есть исправление

    Stored cross-site scripting (XSS) in WordPress block editor

    In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS.

    • Обновитесь до 5.3.2+dfsg1-1
    Опубликовано Обновлено
  2. CVE-2019-16780

    Средний · CVSS 5.8EPSS 1,7%Есть исправление

    Stored cross-site scripting (XSS) in WordPress block editor

    WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.

    • Обновитесь до 5.3.2+dfsg1-1
    Опубликовано Обновлено
  3. CVE-2019-17671

    Средний · CVSS 5.3EPSS 36,5%Публичный эксплойтЕсть исправление

    CVE-2019-17671

    In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.

    • Обновитесь до 5.2.4+dfsg1-1
    Опубликовано Обновлено
  4. CVE-2019-17673

    Высокий · CVSS 7.5EPSS 3,53%Есть исправление

    CVE-2019-17673

    WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.

    • Обновитесь до 5.2.4+dfsg1-1
    Опубликовано Обновлено
  5. CVE-2019-17675

    Высокий · CVSS 8.8EPSS 2,8%Есть исправление

    CVE-2019-17675

    WordPress before 5.2.4 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.

    • Обновитесь до 5.2.4+dfsg1-1
    Опубликовано Обновлено
  6. CVE-2019-17669

    Критический · CVSS 9.8EPSS 5,24%Есть исправление

    CVE-2019-17669

    WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because URL validation does not consider the interpretation of a name as a series of hex characters.

    • Обновитесь до 5.2.4+dfsg1-1
    Опубликовано Обновлено
  7. CVE-2019-17670

    Критический · CVSS 9.8EPSS 4,51%Есть исправление

    CVE-2019-17670

    WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.

    • Обновитесь до 5.2.4+dfsg1-1
    Опубликовано Обновлено
  8. CVE-2019-16222

    Средний · CVSS 6.1EPSS 2,2%Есть исправление

    CVE-2019-16222

    WordPress before 5.2.3 has an issue with URL sanitization in wp_kses_bad_protocol_once in wp-includes/kses.php that can lead to cross-site scripting (XSS) attacks.

    • Обновитесь до 5.2.3+dfsg1-1
    Опубликовано Обновлено
  9. CVE-2019-16223

    Средний · CVSS 5.4EPSS 5,18%Публичный эксплойтЕсть исправление

    CVE-2019-16223

    WordPress before 5.2.3 allows XSS in post previews by authenticated users.

    • Обновитесь до 5.2.3+dfsg1-1
    Опубликовано Обновлено
  10. CVE-2019-16220

    Средний · CVSS 6.1EPSS 2,55%Есть исправление

    CVE-2019-16220

    In WordPress before 5.2.3, validation and sanitization of a URL in wp_validate_redirect in wp-includes/pluggable.php could lead to an open redirect if a provided URL path does not start with a forward slash.

    • Обновитесь до 5.2.3+dfsg1-1
    Опубликовано Обновлено
  11. CVE-2017-6514

    Средний · CVSS 5.3EPSS 3,01%Нет опубликованного исправления

    CVE-2017-6514

    WordPress 4.7.2 mishandles listings of post authors, which allows remote attackers to obtain sensitive information (Path Disclosure) via a /wp-json/oembed/1.0/embed?url= request, related to the "author_name":" substring.

  12. CVE-2019-9787

    Высокий · CVSS 8.8EPSS 38,56%Есть исправление

    CVE-2019-9787

    WordPress before 5.1.1 does not properly filter comment content, leading to Remote Code Execution by unauthenticated users in a default configuration. This occurs because CSRF protection is mishandled, and because Search Engine Optimization of A elements is performed incorrectly, leading to XSS. The XSS results in administrative access, which allows arbitrary changes to .php files. This is related to wp-admin/includes/ajax-actions.php and wp-includes/comment.php.

    • Обновитесь до 5.1.1+dfsg1-1
    Опубликовано Обновлено
  13. CVE-2019-8943

    Средний · CVSS 6.5EPSS 91,98%Публичный эксплойтНет опубликованного исправления

    CVE-2019-8943

    WordPress through 5.0.3 allows Path Traversal in wp_crop_image(). An attacker (who has privileges to crop an image) can write the output image to an arbitrary directory via a filename containing two image extensions and ../ sequences, such as a filename ending with the .jpg?/../../file.jpg substring.

    Опубликовано Обновлено
  14. CVE-2019-8942

    Высокий · CVSS 8.8EPSS 82,74%Публичный эксплойтЕсть исправление

    CVE-2019-8942

    WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

    • Обновитесь до 5.0.1+dfsg1-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →