p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости knot-resolver

За последние 30 дней в knot-resolver опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 15

  1. CVE-2026-66374

    Высокий · CVSS 8.1EPSS 0,62%Есть исправление

    CVE-2026-66374

    Knot Resolver before 6.4.1 allows remote code execution via a heap-based buffer overflow in the DoQ (DNS-over-QUIC) receive path.

    • Обновитесь до 6.4.1-1
  2. CVE-2023-50868

    Высокий · CVSS 7.5EPSS 74,3%Есть исправление

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 5.7.1-1
    Опубликовано Обновлено
  3. CVE-2023-50387

    Высокий · CVSS 7.5EPSS 99,99%Есть исправление

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 5.7.1-1
    Опубликовано Обновлено
  4. CVE-2023-46317

    Высокий · CVSS 7.5EPSS 0,76%Есть исправление

    CVE-2023-46317

    Knot Resolver before 5.7.0 performs many TCP reconnections upon receiving certain nonsensical responses from servers.

    • Обновитесь до 5.7.0-1
    Опубликовано Обновлено
  5. CVE-2023-26249

    Высокий · CVSS 7.5EPSS 0,71%Есть исправление

    CVE-2023-26249

    Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and potentially causing a denial of service. Specifically, a single client query may lead to a hundred TCP connection attempts if a DNS server closes connections without providing a response.

    • Обновитесь до 5.6.0-1
    Опубликовано Обновлено
  6. CVE-2022-40188

    Высокий · CVSS 7.5EPSS 1,95%Есть исправление

    CVE-2022-40188

    Knot Resolver before 5.5.3 allows remote attackers to cause a denial of service (CPU consumption) because of algorithmic complexity. During an attack, an authoritative server must return large NS sets or address sets.

    • Обновитесь до 5.5.3-1
    Опубликовано Обновлено
  7. CVE-2022-32983

    Средний · CVSS 5.3EPSS 0,76%Нет опубликованного исправления

    CVE-2022-32983

    Knot Resolver through 5.5.1 may allow DNS cache poisoning when there is an attempt to limit forwarding actions by filters.

  8. CVE-2021-40083

    Высокий · CVSS 7.5EPSS 1,42%Есть исправление

    CVE-2021-40083

    Knot Resolver before 5.3.2 is prone to an assertion failure, triggerable by a remote attacker in an edge case (NSEC3 with too many iterations used for a positive wildcard proof).

    • Обновитесь до 5.4.1-2
    Опубликовано Обновлено
  9. CVE-2020-12667

    Высокий · CVSS 7.5EPSS 2,61%Есть исправление

    CVE-2020-12667

    Knot Resolver before 5.1.1 allows traffic amplification via a crafted DNS answer from an attacker-controlled server, aka an "NXNSAttack" issue. This is triggered by random subdomains in the NSDNAME in NS records.

    • Обновитесь до 5.1.1-0.1
  10. CVE-2019-19331

    Высокий · CVSS 7.5EPSS 2,11%Есть исправление

    CVE-2019-19331

    knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with very many resource records might be processed very inefficiently, in extreme cases taking even several CPU seconds for each such uncached message. For example, a few thousand A records can be squashed into one DNS message (limit is 64kB).

    • Обновитесь до 5.0.1-1
    Опубликовано Обновлено
  11. CVE-2019-10191

    Средний · CVSS 6.3EPSS 1,93%Есть исправление

    CVE-2019-10191

    A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening possibility of domain hijack using attacks against insecure DNS protocol.

    • Обновитесь до 5.0.1-1
    Опубликовано Обновлено
  12. CVE-2019-10190

    Средний · CVSS 5.4EPSS 1,99%Есть исправление

    CVE-2019-10190

    A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0 before 4.1.0 which allows remote attackers to bypass DNSSEC validation for non-existence answer. NXDOMAIN answer would get passed through to the client even if its DNSSEC validation failed, instead of sending a SERVFAIL packet. Caching is not affected by this particular bug but see CVE-2019-10191.

    • Обновитесь до 5.0.1-1
    Опубликовано Обновлено
  13. CVE-2018-10920

    Высокий · CVSS 7.5EPSS 3,24%Есть исправление

    CVE-2018-10920

    Improper input validation bug in DNS resolver component of Knot Resolver before 2.4.1 allows remote attacker to poison cache.

    • Обновитесь до 2.4.1-1
    Опубликовано Обновлено
  14. CVE-2018-1000002

    Низкий · CVSS 3.7EPSS 1,08%Есть исправление

    CVE-2018-1000002

    Improper input validation bugs in DNSSEC validators components in Knot Resolver (prior version 1.5.2) allow attacker in man-in-the-middle position to deny existence of some data in DNS via packet replay.

    • Обновитесь до 1.5.2-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →