p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости libphp-adodb

За последние 30 дней в libphp-adodb опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 11

  1. CVE-2025-54119

    Критический · CVSS 10EPSS 0,53%Есть исправление

    ADOdb's sqlite3 driver allows SQL injection

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. In versions 5.22.9 and below, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. This is fixed in version 5.22.10. To workaround this issue, only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter.

    • Обновитесь до 5.22.10-0.1
    Опубликовано Обновлено
  2. CVE-2025-46337

    Критический · CVSS 10EPSS 0,74%Есть исправление

    SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

    • Обновитесь до 5.22.9-0.1
  3. CVE-2021-3850

    Критический · CVSS 9.1EPSS 2,17%Есть исправление

    Authentication Bypass by Primary Weakness in adodb/adodb

    Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.

    • Обновитесь до 5.21.4-1
    Опубликовано Обновлено
  4. CVE-2016-4855

    Средний · CVSS 6.1EPSS 1,95%Есть исправление

    CVE-2016-4855

    Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    • Обновитесь до 5.20.6-1
  5. CVE-2016-7405

    Критический · CVSS 9.8EPSS 2,98%Есть исправление

    CVE-2016-7405

    The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

    • Обновитесь до 5.20.6-1
    Опубликовано Обновлено
  6. CVE-2011-3699

    Без оценкиEPSS 1,37%Нет опубликованного исправления

    CVE-2011-3699

    John Lim ADOdb Library for PHP 5.11 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by tests/test-active-record.php and certain other files.

    Опубликовано Обновлено
  7. CVE-2006-4976

    Без оценкиEPSS 1,49%Нет опубликованного исправления

    CVE-2006-4976

    The Date Library in John Lim ADOdb Library for PHP allows remote attackers to obtain sensitive information via a direct request for (1) server.php, (2) adodb-errorpear.inc.php, (3) adodb-iterator.inc.php, (4) adodb-pear.inc.php, (5) adodb-perf.inc.php, (6) adodb-xmlschema.inc.php, and (7) adodb.inc.php; files in datadict including (8) datadict-access.inc.php, (9) datadict-db2.inc.php, (10) datadict-generic.inc.php, (11) datadict-ibase.inc.php, (12) datadict-informix.inc.php, (13) datadict-mssql.inc.php, (14) datadict-mysql.inc.php, (15) datadict-oci8.inc.php, (16) datadict-postgres.inc.php, and (17) datadict-sybase.inc.php; files in drivers/

    Опубликовано Обновлено
  8. CVE-2006-0806

    Без оценкиEPSS 6,01%Публичный эксплойтЕсть исправление

    CVE-2006-0806

    Multiple cross-site scripting (XSS) vulnerabilities in ADOdb 4.71, as used in multiple packages such as phpESP, allow remote attackers to inject arbitrary web script or HTML via (1) the next_page parameter in adodb-pager.inc.php and (2) other unspecified vectors related to PHP_SELF.

    • Обновитесь до 4.72-0.1
    Опубликовано Обновлено
  9. CVE-2006-0410

    Без оценкиEPSS 2,91%Есть исправление

    CVE-2006-0410

    SQL injection vulnerability in ADOdb before 4.71, when using PostgreSQL, allows remote attackers to execute arbitrary SQL commands via unspecified attack vectors involving binary strings.

    • Обновитесь до 4.72-0.1
    Опубликовано Обновлено
  10. CVE-2006-0147

    Без оценкиEPSS 13,06%Публичный эксплойтЕсть исправление

    CVE-2006-0147

    Dynamic code evaluation vulnerability in tests/tmssql.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PhpOpenChat, possibly (7) MAXdev MD-Pro, and (8) Simplog, allows remote attackers to execute arbitrary PHP functions via the do parameter, which is saved in a variable that is then executed as a function, as demonstrated using phpinfo.

    • Обновитесь до 4.72-0.1
    Опубликовано Обновлено
  11. CVE-2006-0146

    Без оценкиEPSS 13,24%Публичный эксплойтЕсть исправление

    CVE-2006-0146

    The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.

    • Обновитесь до 4.72-0.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →