p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости systemd

За последние 30 дней в systemd опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 63

  1. CVE-2026-15060

    Средний · CVSS 4.7EPSS 0,08%Есть исправление

    systemd-machined: unprivileged users can terminate arbitrary processes

    When systemd-machined >= v259 (or v258 with a custom `polkit` policy that allows `register-machine` access) is running on a desktop system, an unprivileged user logged in a desktop graphical session can kill arbitrary processes, even privileged ones. - versions older than v259 are not affected, unless unprivileged access is granted for the `register-machine` polkit action via a local, custom policy config file - versions older than v258 are not affected - unrelated to the systemd service manager (pid 1 or user session managers) - systemd-machined is not typically installed by default, and is typically in an optional, separate package (e.g.:

    • Обновитесь до 261.2-1
    Опубликовано Обновлено
  2. CVE-2026-16742

    Средний · CVSS 6.7EPSS 0,06%Есть исправление

    systemd-homed: local privilege escalation via missing home-record signature verification on the authenticate path

    systemd-homed contains a local privilege escalation bug via arbitrary system group addition to a local, logged in, homed-managed user

    • Обновитесь до 261.2-1
    Опубликовано Обновлено
  3. CVE-2026-15059

    Средний · CVSS 5.5EPSS 0,16%Есть исправление

    systemd-oomd: unprivileged users can terminate arbitrary processes

    Local unprivileged users can terminate arbitrary local processes via a systemd-oomd IPC API due to a missing path traversal validation.

    • Обновитесь до 261~rc3-1
    Опубликовано Обновлено
  4. CVE-2026-40228

    Низкий · CVSS 2.9EPSS 0,17%Нет опубликованного исправления

    CVE-2026-40228

    In systemd 259, systemd-journald can send ANSI escape sequences to the terminals of arbitrary users when a "logger -p emerg" command is executed, if ForwardToWall=yes is set.

  5. CVE-2026-40224

    Средний · CVSS 6.7EPSS 0,11%Публичный эксплойтЕсть исправление

    CVE-2026-40224

    In systemd 259 before 260, there is local privilege escalation in systemd-machined because varlink can be used to reach the root namespace.

    • Обновитесь до 260~rc2-1
    Опубликовано Обновлено
  6. CVE-2026-29111

    Средний · CVSS 5.5EPSS 0,13%Есть исправление

    systemd: Local unprivileged user can trigger an assert

    systemd, a system and service manager, (as PID 1) hits an assert and freezes execution when an unprivileged IPC API call is made with spurious data. On version v249 and older the effect is not an assert, but stack overwriting, with the attacker controlled content. From version v250 and newer this is not possible as the safety check causes an assert instead. This IPC call was added in v239, so versions older than that are not affected. Versions 260-rc1, 259.2, 258.5, and 257.11 contain patches. No known workarounds are available.

    • Обновитесь до 260~rc2-1
  7. CVE-2026-4105

    Средний · CVSS 6.7EPSS 0,15%Есть исправление

    Systemd: systemd: privilege escalation via improper access control in registermachine d-bus method

    A flaw was found in systemd. The systemd-machined service contains an Improper Access Control vulnerability due to insufficient validation of the class parameter in the RegisterMachine D-Bus (Desktop Bus) method. A local unprivileged user can exploit this by attempting to register a machine with a specific class value, which may leave behind a usable, attacker-controlled machine object. This allows the attacker to invoke methods on the privileged object, leading to the execution of arbitrary commands with root privileges on the host system.

    • Обновитесь до 260~rc3-1
    Опубликовано Обновлено
  8. CVE-2025-4598

    Средний · CVSS 4.7EPSS 1,28%Есть исправление

    Systemd-coredump: race condition that allows a local attacker to crash a suid program and gain read access to the resulting core dump

    A vulnerability was found in systemd-coredump. This flaw allows an attacker to force a SUID process to crash and replace it with a non-SUID binary to access the original's privileged process coredump, allowing the attacker to read sensitive data, such as /etc/shadow content, loaded by the original process. A SUID binary or process has a special type of permission, which allows the process to run with the file owner's permissions, regardless of the user executing the binary. This allows the process to access more restricted data than unprivileged users or processes would be able to. An attacker can leverage this flaw by forcing a SUID process

    • Обновитесь до 257.6-1
  9. CVE-2023-50868

    Высокий · CVSS 7.5EPSS 74,3%Есть исправление

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 255.4-1
    Опубликовано Обновлено
  10. CVE-2023-50387

    Высокий · CVSS 7.5EPSS 99,99%Есть исправление

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 255.4-1
    Опубликовано Обновлено
  11. CVE-2023-7008

    Средний · CVSS 5.9EPSS 0,85%Есть исправление

    Systemd-resolved: unsigned name response in signed zone is not refused when dnssec=yes

    A vulnerability was found in systemd-resolved. This issue may allow systemd-resolved to accept records of DNSSEC-signed domains even when they have no signature, allowing man-in-the-middles (or the upstream DNS resolver) to manipulate records.

    • Обновитесь до 255.1-3
    Опубликовано Обновлено
  12. CVE-2023-31439

    Средний · CVSS 5.3EPSS 0,35%Нет опубликованного исправления

    CVE-2023-31439

    An issue was discovered in systemd 253. An attacker can modify the contents of past events in a sealed log file and then adjust the file such that checking the integrity shows no error, despite modifications. NOTE: the vendor reportedly sent "a reply denying that any of the finding was a security vulnerability."

  13. CVE-2023-31438

    Средний · CVSS 5.3EPSS 0,33%Нет опубликованного исправления

    CVE-2023-31438

    An issue was discovered in systemd 253. An attacker can truncate a sealed log file and then resume log sealing such that checking the integrity shows no error, despite modifications. NOTE: the vendor reportedly sent "a reply denying that any of the finding was a security vulnerability."

  14. CVE-2023-31437

    Средний · CVSS 5.3EPSS 0,34%Нет опубликованного исправления

    CVE-2023-31437

    An issue was discovered in systemd 253. An attacker can modify a sealed log file such that, in some views, not all existing and sealed log messages are displayed. NOTE: the vendor reportedly sent "a reply denying that any of the finding was a security vulnerability."

  15. CVE-2023-26604

    Высокий · CVSS 7.8EPSS 1,05%Есть исправление

    CVE-2023-26604

    systemd before 247 does not adequately block local privilege escalation for some Sudo configurations, e.g., plausible sudoers files in which the "systemctl status" command may be executed. Specifically, systemd does not set LESSSECURE to 1, and thus other programs may be launched from the less program. This presents a substantial security risk when running systemctl from Sudo, because less executes as root when the terminal size is too small to show the complete systemctl output.

    • Обновитесь до 247.1-2
    Опубликовано Обновлено
  16. CVE-2022-4415

    Средний · CVSS 5.5EPSS 0,82%Есть исправление

    CVE-2022-4415

    A vulnerability was found in systemd. This security flaw can cause a local information leak due to systemd-coredump not respecting the fs.suid_dumpable kernel setting.

    • Обновитесь до 252.4-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →