p PatchFirst

GHSA-r5xw-q988-826m

GHSA-r5xw-q988-826m · Remote Memory Exposure in mongoose

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Versions of `mongoose` before 4.3.6, 3.8.39 are vulnerable to remote memory exposure. Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database. ## Recommendation Update to version 4.3.6, 3.8.39 or later.

CVSS 5.1 · Средний · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • mongoose npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.5.5, < 3.8.39

    Обновитесь до 3.8.39

  • mongoose npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.3.6

    Обновитесь до 4.3.6

Первоисточники

Проверьте свой сервер →