p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости mongoose

За последние 30 дней в mongoose опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 9

  1. CVE-2026-73562

    Средний · CVSS 6.5EPSS 0,5%Есть исправление

    Mongoose: Prototype pollution in the update casting via __proto__-prefixed dotted path (Schema._getSchema/path getter)

    Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.10, 7.8.10, 8.24.1, and 9.7.2, passing a user-controlled update such as MyModel.updateOne(filter, req.body) can exploit Mongoose update casting with a __proto__.x dotted path under $set. Schema.prototype.path and Schema.prototype._getPathType can treat inherited properties of schema.paths and schema.nested as schema types, allowing the casting process to set $fullPath and $parentSchemaDocArray on Object.prototype before throwing. This prototype pollution makes those properties visible on newly created objects and can cause application int

    • Обновитесь до 6.13.10
    • Обновитесь до 7.8.10
    • Обновитесь до 8.24.1
    • Обновитесь до 9.7.2
    Опубликовано Обновлено
  2. CVE-2026-42334

    Высокий · CVSS 7.5EPSS 0,27%Есть исправление

    Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection

    Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being saniti

    • Обновитесь до 6.13.9
    • Обновитесь до 7.8.9
    • Обновитесь до 8.22.1
    • Обновитесь до 9.1.6
    Опубликовано Обновлено
  3. CVE-2025-23061

    Критический · CVSS 9EPSS 7,24%Публичный эксплойтЕсть исправление

    CVE-2025-23061

    Mongoose before 8.9.5 can improperly use a nested $where filter with a populate() match, leading to search injection. NOTE: this issue exists because of an incomplete fix for CVE-2024-53900.

    • Обновитесь до 6.13.6
    • Обновитесь до 7.8.4
    • Обновитесь до 8.9.5
    Опубликовано Обновлено
  4. CVE-2024-53900

    Критический · CVSS 9.1EPSS 3,98%Публичный эксплойтЕсть исправление

    CVE-2024-53900

    Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

    • Обновитесь до 5.13.23
    • Обновитесь до 6.13.5
    • Обновитесь до 7.8.3
    • Обновитесь до 8.8.3
    Опубликовано Обновлено
  5. CVE-2023-3696

    Критический · CVSS 10EPSS 1,21%Есть исправление

    Prototype Pollution in automattic/mongoose

    Prototype Pollution in GitHub repository automattic/mongoose prior to 7.3.4.

    • Обновитесь до 5.13.20
    • Обновитесь до 6.11.3
    • Обновитесь до 7.3.3
    Опубликовано Обновлено
  6. CVE-2022-24304

    Критический · CVSS 9.8Есть исправление

    Mongoose Vulnerable to Prototype Pollution in Schema Object

    ### Description Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Affected versions of this package are vulnerable to Prototype Pollution. The `Schema.path()` function is vulnerable to prototype pollution when setting the `schema` object. This vulnerability allows modification of the Object prototype and could be manipulated into a Denial of Service (DoS) attack. ### Proof of Concept ```js // poc.js const mongoose = require('mongoose'); const schema = new mongoose.Schema(); malicious_payload = '__proto__.toString' schema.path(malicious_payload, [String]) x = {} console.log(x.toString()) // crashe

    • Обновитесь до 5.13.15
    • Обновитесь до 6.4.6
    Опубликовано Обновлено
  7. GHSA-r5xw-q988-826m

    Средний · CVSS 5.1Есть исправление

    Remote Memory Exposure in mongoose

    Versions of `mongoose` before 4.3.6, 3.8.39 are vulnerable to remote memory exposure. Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database. ## Recommendation Update to version 4.3.6, 3.8.39 or later.

    • Обновитесь до 3.8.39
    • Обновитесь до 4.3.6
    Опубликовано Обновлено
  8. CVE-2019-17426

    Критический · CVSS 9.1EPSS 1,5%Есть исправление

    CVE-2019-17426

    Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).

    • Обновитесь до 4.13.21
    • Обновитесь до 5.7.5
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →