p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости @langchain/community

За последние 30 дней в @langchain/community опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 3

  1. CVE-2026-27795

    Средний · CVSS 4.1EPSS 0,25%Есть исправление

    LangChain Community: redirect chaining can lead to SSRF bypass via RecursiveUrlLoader

    LangChain is a framework for building LLM-powered applications. Prior to version 1.1.8, a redirect-based Server-Side Request Forgery (SSRF) bypass exists in `RecursiveUrlLoader` in `@langchain/community`. The loader validates the initial URL but allows the underlying fetch to follow redirects automatically, which permits a transition from a safe public URL to an internal or metadata endpoint without revalidation. This is a bypass of the SSRF protections introduced in 1.1.14 (CVE-2026-26019). Users should upgrade to `@langchain/community` 1.1.18, which validates every redirect hop by disabling automatic redirects and re-validating `Location` t

    • Обновитесь до 1.1.18
    Опубликовано Обновлено
  2. CVE-2026-26019

    Средний · CVSS 4.1EPSS 0,4%Есть исправление

    @langchain/community affected by SSRF Bypass in RecursiveUrlLoader via insufficient URL origin validation

    LangChain is a framework for building LLM-powered applications. Prior to 1.1.14, the RecursiveUrlLoader class in @langchain/community is a web crawler that recursively follows links from a starting URL. Its preventOutside option (enabled by default) is intended to restrict crawling to the same site as the base URL. The implementation used String.startsWith() to compare URLs, which does not perform semantic URL validation. An attacker who controls content on a crawled page could include links to domains that share a string prefix with the target, causing the crawler to follow links to attacker-controlled or internal infrastructure. Additionall

    • Обновитесь до 1.1.14
    Опубликовано Обновлено
  3. CVE-2024-7042

    Средний · CVSS 4.9EPSS 0,31%Есть исправление

    Prompt Injection in langchain-ai/langchainjs Leading to SQL Injection

    A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection. This vulnerability permits unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

    • Обновитесь до 0.3.3
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →