p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости hummus

За последние 30 дней в hummus опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 4

  1. CVE-2022-41957

    Высокий · CVSS 7.5EPSS 1,13%Нет опубликованного исправления

    muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference

    Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

    Опубликовано Обновлено
  2. CVE-2022-39381

    Высокий · CVSS 7.5EPSS 0,89%Есть исправление

    Unchecked Return Value to NULL Pointer Dereference in PDFDocumentHandler.cpp

    Muhammara is a node module with c/cpp bindings to modify PDF with js for node or electron (based/replacement on/of galkhana/hummusjs). The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be appended to another. This issue has been patched in 2.6.0 for muhammara and not at all for hummus. As a workaround, do not process files from untrusted sources.

    • Обновитесь до 1.0.111
    Опубликовано Обновлено
  3. CVE-2022-25885

    Высокий · CVSS 7.5EPSS 1,49%Есть исправление

    Denial of Service (DoS)

    The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when PDFStreamForResponse() is used with invalid data.

    • Обновитесь до 1.0.111
  4. CVE-2022-25892

    Высокий · CVSS 7.5EPSS 1,36%Есть исправление

    Denial of Service (DoS)

    The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.

    • Обновитесь до 1.0.111

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →