p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости validator

За последние 30 дней в validator опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 10

  1. CVE-2025-12758

    Высокий · CVSS 8.7EPSS 0,55%Есть исправление

    CVE-2025-12758

    Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.

    • Обновитесь до 13.15.22
    Опубликовано Обновлено
  2. CVE-2025-56200

    Средний · CVSS 6.1EPSS 0,32%Есть исправление

    CVE-2025-56200

    A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.

    • Обновитесь до 13.15.20
    Опубликовано Обновлено
  3. GHSA-xx4c-jj58-r7x6

    Средний · CVSS 5.3Есть исправление

    Inefficient Regular Expression Complexity in Validator.js

    ### Impact Versions of `validator` prior to 13.7.0 are affected by an inefficient Regular Expression complexity when using the `rtrim` and `trim` sanitizers. ### Patches The problem has been patched in validator 13.7.0

    • Обновитесь до 13.7.0
  4. CVE-2014-8882

    Высокий · CVSS 7.5Есть исправление

    Regular Expression Denial of Service in validator

    Versions of `validator` prior to 3.22.1 are affected by a regular expression denial of service vulnerability in the `isURL` method. ## Recommendation Update to version 3.22.1 or later.

    • Обновитесь до 3.22.1
    Опубликовано Обновлено
  5. CVE-2013-7453

    Средний · CVSS 6.1EPSS 1,85%Есть исправление

    CVE-2013-7453

    The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via vectors related to UI redressing.

    • Обновитесь до 1.1.0
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →