p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости adodb/adodb-php

За последние 30 дней в adodb/adodb-php опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 6

  1. CVE-2025-54119

    Критический · CVSS 10EPSS 0,53%Есть исправление

    ADOdb's sqlite3 driver allows SQL injection

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. In versions 5.22.9 and below, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. This is fixed in version 5.22.10. To workaround this issue, only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter.

    • Обновитесь до 5.22.10
    Опубликовано Обновлено
  2. CVE-2025-46337

    Критический · CVSS 10EPSS 0,74%Есть исправление

    SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

    • Обновитесь до 5.22.9
  3. CVE-2021-3850

    Критический · CVSS 9.1EPSS 2,17%Есть исправление

    Authentication Bypass by Primary Weakness in adodb/adodb

    Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.

    • Обновитесь до 5.20.21
    • Обновитесь до 5.21.4
    Опубликовано Обновлено
  4. CVE-2016-4855

    Средний · CVSS 6.1EPSS 1,95%Есть исправление

    CVE-2016-4855

    Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    • Обновитесь до 5.20.6
  5. CVE-2016-7405

    Критический · CVSS 9.8EPSS 2,98%Есть исправление

    CVE-2016-7405

    The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

    • Обновитесь до 5.20.7
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →