p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости guzzlehttp/oauth-subscriber

За последние 30 дней в guzzlehttp/oauth-subscriber опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 1

  1. CVE-2025-21617

    Средний · CVSS 6.3EPSS 0,48%Есть исправление

    Guzzle OAuth Subscriber has insufficient nonce entropy

    Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.

    • Обновитесь до 0.8.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →