p PatchFirst

PatchFirst · Свежие уязвимости

librenms/librenms 26.2.0: известные уязвимости

Известных уязвимостей, затрагивающих librenms/librenms 26.2.0: 8. Сравните исправленные версии ниже с установленной у вас.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 8

  1. CVE-2026-84192

    Высокий · CVSS 7.1EPSS 0,33%Есть исправление

    LibreNMS before 26.3.1 Stored XSS via SNMP/Syslog Data

    LibreNMS before 26.3.1 contains a stored cross-site scripting vulnerability in legacy PHP templates that output SNMP-sourced and syslog-sourced data without escaping. An attacker who controls a monitored network device can inject arbitrary JavaScript through SNMP interface descriptions or syslog program fields that executes when authenticated users view affected pages.

    • Обновитесь до 26.5.0
    Опубликовано Обновлено
  2. CVE-2026-84190

    Высокий · CVSS 8.7EPSS 0,86%Есть исправление

    LibreNMS before 26.5.0 Remote Code Execution via AboutController

    LibreNMS versions before 26.5.0 contain a remote code execution vulnerability in the AboutController where the snmpget configuration parameter is passed to shell_exec() without proper validation. An authenticated administrator can modify the snmpget configuration to point to a malicious executable file and trigger code execution by accessing the /about endpoint.

    • Обновитесь до 26.5.0
    Опубликовано Обновлено
  3. CVE-2026-84189

    Критический · CVSS 9.2EPSS 0,38%Есть исправление

    LibreNMS before 26.7.0 Stored XSS via Oxidized API

    LibreNMS through 26.4.0 renders JSON fields (name, ip, model, author, commit message) returned by the admin-configurable Oxidized integration URL (oxidized.url) into the device showconfig page without applying htmlspecialchars(). An administrator who points the Oxidized URL at an attacker-controlled server (SSRF) can cause it to return malicious JSON, resulting in stored/persistent cross-site scripting affecting all users who view any device's showconfig tab. Fixed in 26.7.0.

    • Обновитесь до 26.7.0
    Опубликовано Обновлено
  4. CVE-2026-84188

    Средний · CVSS 4.8EPSS 0,25%Есть исправление

    librenms before 26.7.0 Stored XSS via graph_descr settings

    LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.

    • Обновитесь до 26.7.0
    Опубликовано Обновлено
  5. CVE-2026-55182

    Высокий · CVSS 8.6EPSS 1,61%Есть исправление

    LibreNMS: Remote Code Execution by Signal Alert Transportation Module

    LibreNMS is a network monitoring system. In versions from 21.6.0 up to 26.5.0, the Signal alert transport is vulnerable to command injection because the signal-cli path and the Recipient field of an alert transport entry are insufficiently escaped before being passed to an exec call. An authenticated administrator can craft a transport entry whose Recipient contains shell metacharacters and whose path points to the bundled composer_wrapper.php script, which itself passes attacker-controlled input to further unsafe exec calls. By chaining these calls, the administrator can execute arbitrary operating-system commands on the LibreNMS host. This

    • Обновитесь до 26.5.0
    Опубликовано Обновлено
  6. CVE-2026-45694

    Средний · CVSS 5.4EPSS 0,24%Есть исправление

    LibreNMS: Reflected XSS in the Proxmox app view via unsanitized instance/vmid parameters

    LibreNMS is a network monitoring system. In versions up to and including 26.4.0, the Proxmox application view is vulnerable to reflected cross-site scripting through the user-supplied instance and vmid GET parameters, which are reflected into the page title without adequate encoding. The parameters are placed into the page title with only strip_tags applied, and the title is then written into an inline document.title assignment through string interpolation, so a single quote terminates the JavaScript string and the remaining input runs as script. An attacker who lures an authenticated user into following a crafted link can execute script in t

    • Обновитесь до 26.5.0
    Опубликовано Обновлено
  7. CVE-2026-6204

    Высокий · CVSS 8.5EPSS 7,53%Есть исправление

    CVE-2026-6204

    LibreNMS versions before 26.3.0 are affected by an authenticated remote code execution vulnerability by abusing the Binary Locations config and the Netcommand feature. Successful exploitation requires administrative privileges. Exploitation could result in compromise of the underlying web server.

    • Обновитесь до 26.3.0
    Опубликовано Обновлено
  8. CVE-2026-2728

    Средний · CVSS 4.6EPSS 0,22%Есть исправление

    CVE-2026-2728

    LibreNMS versions before 26.3.0 are affected by an authenticated Cross-site Scripting vulnerability on the showconfig page. Successful exploitation requires administrative privileges. Exploitation could result in XSS attacks being performed against other users with access to the page.

    • Обновитесь до 26.3.0
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →