p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости solspace/craft-freeform

За последние 30 дней в solspace/craft-freeform опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 6

  1. CVE-2026-73858

    Средний · CVSS 5.3EPSS 0,55%Публичный эксплойтЕсть исправление

    Solspace Freeform: Limited Twig template injection via submitted field values

    Solspace Freeform plugin for Craft CMS 5.x is a super flexible form-building tool. From 5.0.0 through 5.10.13, submitted values from public Freeform forms can be evaluated by the isolated Twig renderer when rendered into HTML attributes. An unauthenticated attacker can place Twig expressions in submitted field values, including value attributes, and receive evaluated PHP, operating-system, or Craft filesystem-path constants in the form response. The isolated context was not shown to expose Craft globals, environment variables, credentials, arbitrary files, or code execution, so the confirmed impact is limited server and environment informatio

    • Обновитесь до 5.10.14
    Опубликовано Обновлено
  2. CVE-2026-26188

    Средний · CVSS 5.1EPSS 0,3%Есть исправление

    Solspace Freeform plugin affected by Stored Cross-Site Scripting (XSS) in Freeform Craft Plugin CP UI (builder/integrations)

    Solspace Freeform plugin for Craft CMS 5.x is a super flexible form-building tool. An authenticated, low-privilege user (able to create/edit forms) can inject arbitrary HTML/JS into the Craft Control Panel (CP) builder and integrations views. User-controlled form labels and integration metadata are rendered with dangerouslySetInnerHTML without sanitization, leading to stored XSS that executes when any admin views the builder/integration screens. This vulnerability is fixed in 5.14.7.

    • Обновитесь до 5.14.7
    Опубликовано Обновлено
  3. GHSA-rwr8-xrpw-9qf5

    Без оценкиЕсть исправление

    solspace/craft-freeform Exposed to Known Axios Vulnerabilities via Precompiled Assets

    ### Summary The latest versions of both 4.x and 5.x are using Axios versions < 1.7.5 and as such are subject to known vulnerabilities as per: https://security.snyk.io/package/npm/axios ### Details We've had this flagged up in a pen test, which indicates the issue stems from this script: /freeform/plugin.js. I couldn't see any reference to vulnerable axios versions in your package.json files, but noticed some precompiled files in packages/plugin so I'm assuming those are where the issue lies.

    • Обновитесь до 4.1.22
    • Обновитесь до 5.5.9
    Опубликовано Обновлено
  4. GHSA-44jg-mv3h-wj6g

    Средний · CVSS 4.8Есть исправление

    solspace/craft-freeform Vulnerable to XSS in `PhpSpreadsheet` HTML Writer Due to Unsanitized Styling Data

    ### Summary _Short summary of the problem. Make the impact and severity as clear as possible. For example: An unsafe deserialization vulnerability allows any unauthenticated user to execute arbitrary code on the server._ \PhpOffice\PhpSpreadsheet\Writer\Html doesn't sanitize spreadsheet styling information such as font names, allowing an attacker to inject arbitrary JavaScript on the page. ### Details _Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer._ See https://github.com/advisories/GHSA-wgmf-q9vr-vww6 ### PoC _Complete instructions, including specific configuration deta

    • Обновитесь до 4.1.23
    Опубликовано Обновлено
  5. GHSA-58q2-9x27-h2jm

    Средний · CVSS 6.9Есть исправление

    solspace/craft-freeform Has a DoS Vulnerability

    ### Summary Freeform plugin v4.1.29 uses vulnerable Axios ^1.7.7 allowing unauthenticated attackers to crash servers via malicious data: URIs causing memory exhaustion (CVE-2025-58754). Freeform version: 4.1.29 Craft CMS version: 4.16.8 ### Impact When Axios runs on Node.js and is given a URL with the `data:` scheme, it does not perform HTTP. Instead, its Node http adapter decodes the entire payload into memory (`Buffer`/`Blob`) and returns a synthetic 200 response. This path ignores `maxContentLength` / `maxBodyLength` (which only protect HTTP responses), so an attacker can supply a very large `data:` URI and cause the process to allocate

    • Обновитесь до 4.1.30
    Опубликовано Обновлено
  6. CVE-2025-52122

    Критический · CVSS 9.8EPSS 0,61%Есть исправление

    CVE-2025-52122

    Freeform 5.0.0 to before 5.10.16, a plugin for CraftCMS, contains an Server-side template injection (SSTI) vulnerability, resulting in arbitrary code injection for all users that have access to editing a form (submission title).

    • Обновитесь до 5.10.16
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →