p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости apache-airflow · Страница 8

За последние 30 дней в apache-airflow опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 158

  1. CVE-2020-17515

    Средний · CVSS 6.1EPSS 16,21%Есть исправление

    CVE-2020-17515

    The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions prior to 1.10.13. This is same as CVE-2020-13944 but the implemented fix in Airflow 1.10.13 did not fix the issue completely.

    • Обновитесь до 1.10.13
    • Обновитесь до 1.10.15rc1
    • Обновитесь до 2.0.2rc1
    Опубликовано Обновлено
  2. CVE-2020-13927

    Критический · CVSS 9.8EPSS 99,78%В каталоге KEVПубличный эксплойтЕсть исправление

    CVE-2020-13927

    The previous default setting for Airflow's Experimental API was to allow all API requests without authentication, but this poses security risks to users who miss this fact. From Airflow 1.10.11 the default has been changed to deny all requests by default and is documented at https://airflow.apache.org/docs/1.10.11/security.html#api-authentication. Note this change fixes it for new installs but existing users need to change their config to default `[api]auth_backend = airflow.api.auth.backend.deny_all` as mentioned in the Updating Guide: https://github.com/apache/airflow/blob/1.10.11/UPDATING.md#experimental-api-will-deny-all-request-by-defaul

    • Обновитесь до 1.10.11
    Опубликовано Обновлено
  3. CVE-2020-13944

    Средний · CVSS 6.1EPSS 25,08%Есть исправление

    CVE-2020-13944

    In Apache Airflow < 1.10.12, the "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit.

    • Обновитесь до 1.10.12
    Опубликовано Обновлено
  4. CVE-2020-9485

    Средний · CVSS 6.1EPSS 2,76%Есть исправление

    CVE-2020-9485

    An issue was found in Apache Airflow versions 1.10.10 and below. A stored XSS vulnerability was discovered in the Chart pages of the the "classic" UI.

    • Обновитесь до 1.10.11
    • Обновитесь до 1.10.11rc1
    Опубликовано Обновлено
  5. CVE-2020-11983

    Средний · CVSS 5.4EPSS 1,77%Есть исправление

    CVE-2020-11983

    An issue was found in Apache Airflow versions 1.10.10 and below. It was discovered that many of the admin management screens in the new/RBAC UI handled escaping incorrectly, allowing authenticated users with appropriate permissions to create stored XSS attacks.

    • Обновитесь до 1.10.11
    • Обновитесь до 1.10.11rc1
    Опубликовано Обновлено
  6. CVE-2020-11982

    Критический · CVSS 9.8EPSS 7,22%Есть исправление

    CVE-2020-11982

    An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.

    • Обновитесь до 1.10.11
    • Обновитесь до 1.10.11rc1
    Опубликовано Обновлено
  7. CVE-2020-11981

    Критический · CVSS 9.8EPSS 36,79%Публичный эксплойтЕсть исправление

    CVE-2020-11981

    An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attacker can connect to the broker (Redis, RabbitMQ) directly, it is possible to inject commands, resulting in the celery worker running arbitrary commands.

    • Обновитесь до 1.10.11rc1
    Опубликовано Обновлено
  8. CVE-2020-11978

    Высокий · CVSS 8.8EPSS 99,19%В каталоге KEVПубличный эксплойтЕсть исправление

    CVE-2020-11978

    An issue was found in Apache Airflow versions 1.10.10 and below. A remote code/command injection vulnerability was discovered in one of the example DAGs shipped with Airflow which would allow any authenticated user to run arbitrary commands as the user running airflow worker/scheduler (depending on the executor in use). If you already have examples disabled by setting load_examples=False in the config then you are not vulnerable.

    • Обновитесь до 1.10.11rc1
    Опубликовано Обновлено
  9. CVE-2019-12398

    Средний · CVSS 4.8EPSS 2,82%Есть исправление

    CVE-2019-12398

    In Apache Airflow before 1.10.5 when running with the "classic" UI, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views. The new "RBAC" UI is unaffected.

    • Обновитесь до 1.10.5
    Опубликовано Обновлено
  10. CVE-2019-12417

    Средний · CVSS 4.8EPSS 1,28%Есть исправление

    CVE-2019-12417

    A malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views. This also presented a Local File Disclosure vulnerability to any file readable by the webserver process.

    • Обновитесь до 1.10.6rc1
    Опубликовано Обновлено
  11. CVE-2019-0216

    Средний · CVSS 5.3EPSS 2,66%Есть исправление

    CVE-2019-0216

    A malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

    • Обновитесь до 1.10.3
    • Обновитесь до 1.10.3b1
    Опубликовано Обновлено
  12. CVE-2019-0229

    Высокий · CVSS 8.8EPSS 1,56%Есть исправление

    CVE-2019-0229

    A number of HTTP endpoints in the Airflow webserver (both RBAC and classic) did not have adequate protection and were vulnerable to cross-site request forgery attacks.

    • Обновитесь до 1.10.3
    • Обновитесь до 1.10.3b1
    Опубликовано Обновлено
  13. CVE-2018-20244

    Средний · CVSS 5.5EPSS 1,96%Есть исправление

    CVE-2018-20244

    In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

    • Обновитесь до 1.10.2
    Опубликовано Обновлено
  14. CVE-2018-20245

    Высокий · CVSS 8.7EPSS 1,02%Есть исправление

    CVE-2018-20245

    The LDAP auth backend (airflow.contrib.auth.backends.ldap_auth) prior to Apache Airflow 1.10.1 was misconfigured and contained improper checking of exceptions which disabled server certificate checking.

    • Обновитесь до 1.10.1
    Опубликовано Обновлено
  15. CVE-2017-17836

    Критический · CVSS 9.8EPSS 3,19%Есть исправление

    CVE-2017-17836

    In Apache Airflow 1.8.2 and earlier, an experimental Airflow feature displayed authenticated cookies, as well as passwords to databases used by Airflow. An attacker who has limited access to airflow, whether it be via XSS or by leaving a machine unlocked can exfiltrate all credentials from the system.

    • Обновитесь до 1.9.0
    Опубликовано Обновлено
  16. CVE-2017-12614

    Средний · CVSS 6.1EPSS 2,02%Есть исправление

    CVE-2017-12614

    It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.

    • Обновитесь до 1.9.0
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →