p PatchFirst

PatchFirst · Свежие уязвимости

torch 2.5.1: известные уязвимости

Сравнение для torch 2.5.1 выполнено не полностью. Ниже приведены подтверждённые совпадения.

Фильтры уязвимостей
Сбросить фильтры

Не удалось сравнить 7 записей. Результаты неполные.

Уязвимостей: 19

  1. CVE-2026-4538

    Средний · CVSS 4.8EPSS 0,24%Нет опубликованного исправления

    PyTorch pt2 Loading deserialization

    A vulnerability was identified in PyTorch 2.10.0. The affected element is an unknown function of the component pt2 Loading Handler. The manipulation leads to deserialization. The attack can only be performed from a local environment. The exploit is publicly available and might be used. The project was informed of the problem early through a pull request but has not reacted yet.

  2. CVE-2026-24747

    Высокий · CVSS 8.8EPSS 0,8%Есть исправление

    PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files

    PyTorch is a Python package that provides tensor computation. Prior to version 2.10.0, a vulnerability in PyTorch's `weights_only` unpickler allows an attacker to craft a malicious checkpoint file (`.pth`) that, when loaded with `torch.load(..., weights_only=True)`, can corrupt memory and potentially lead to arbitrary code execution. Version 2.10.0 fixes the issue.

    • Обновитесь до 2.10.0
  3. CVE-2025-55560

    Высокий · CVSS 7.5EPSS 0,41%Есть исправление

    CVE-2025-55560

    An issue in pytorch v2.7.0 can lead to a Denial of Service (DoS) when a PyTorch model consists of torch.Tensor.to_sparse() and torch.Tensor.to_dense() and is compiled by Inductor.

    • Обновитесь до 2.7.1
    Опубликовано Обновлено
  4. CVE-2025-55558

    Высокий · CVSS 7.5EPSS 0,45%Есть исправление

    CVE-2025-55558

    A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of torch.nn.Conv2d, torch.nn.functional.hardshrink, and torch.Tensor.view-torch.mv() and is compiled by Inductor, leading to a Denial of Service (DoS).

    • Обновитесь до 2.7.1
    Опубликовано Обновлено
  5. CVE-2025-55557

    Высокий · CVSS 7.5EPSS 0,41%Есть исправление

    CVE-2025-55557

    A Name Error occurs in pytorch v2.7.0 when a PyTorch model consists of torch.cummin and is compiled by Inductor, leading to a Denial of Service (DoS).

    • Обновитесь до 2.7.1
    Опубликовано Обновлено
  6. CVE-2025-32434

    Критический · CVSS 9.3EPSS 2,37%Есть исправление

    PyTorch: `torch.load` with `weights_only=True` leads to remote code execution

    PyTorch is a Python package that provides tensor computation with strong GPU acceleration and deep neural networks built on a tape-based autograd system. In version 2.5.1 and prior, a Remote Command Execution (RCE) vulnerability exists in PyTorch when loading a model using torch.load with weights_only=True. This issue has been patched in version 2.6.0.

    • Обновитесь до 2.6.0
    Опубликовано Обновлено
  7. CVE-2025-3730

    Средний · CVSS 4.8EPSS 0,33%Есть исправление

    PyTorch LossCTC.cpp torch.nn.functional.ctc_loss denial of service

    A vulnerability, which was classified as problematic, was found in PyTorch 2.6.0. Affected is the function torch.nn.functional.ctc_loss of the file aten/src/ATen/native/LossCTC.cpp. The manipulation leads to denial of service. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. The name of the patch is 46fc5d8e360127361211cb237d5f9eef0223e567. It is recommended to apply a patch to fix this issue. The security policy of the project warns to use unknown models which might establish malicious effects.

    • Обновитесь до 2.8.0
  8. CVE-2025-3001

    Средний · CVSS 4.8EPSS 0,2%Есть исправление

    PyTorch torch.lstm_cell memory corruption

    A vulnerability classified as critical was found in PyTorch 2.6.0. This vulnerability affects the function torch.lstm_cell. The manipulation leads to memory corruption. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used.

    • Обновитесь до 2.10.0
  9. CVE-2025-3000

    Средний · CVSS 4.8EPSS 0,2%Есть исправление

    PyTorch torch.jit.script memory corruption

    A vulnerability classified as critical has been found in PyTorch 2.6.0. This affects the function torch.jit.script. The manipulation leads to memory corruption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used.

    • Обновитесь до 2.13.0
  10. CVE-2025-2999

    Средний · CVSS 4.8EPSS 0,2%Есть исправление

    PyTorch torch.nn.utils.rnn.unpack_sequence memory corruption

    A vulnerability was found in PyTorch 2.6.0. It has been rated as critical. Affected by this issue is the function torch.nn.utils.rnn.unpack_sequence. The manipulation leads to memory corruption. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used.

    • Обновитесь до 2.9.1
  11. CVE-2025-2998

    Средний · CVSS 4.8EPSS 0,2%Нет опубликованного исправления

    PyTorch torch.nn.utils.rnn.pad_packed_sequence memory corruption

    A vulnerability was found in PyTorch 2.6.0. It has been declared as critical. Affected by this vulnerability is the function torch.nn.utils.rnn.pad_packed_sequence. The manipulation leads to memory corruption. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used.

  12. CVE-2025-2953

    Средний · CVSS 4.8EPSS 0,26%Есть исправление

    PyTorch torch.mkldnn_max_pool2d denial of service

    A vulnerability, which was classified as problematic, has been found in PyTorch 2.6.0+cu124. Affected by this issue is the function torch.mkldnn_max_pool2d. The manipulation leads to denial of service. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. The security policy of the project warns to use unknown models which might establish malicious effects.

    • Обновитесь до 2.7.1-rc1
    Опубликовано Обновлено
  13. CVE-2025-2149

    Низкий · CVSS 2.0EPSS 0,26%Нет опубликованного исправления

    PyTorch Quantized Sigmoid Module nnq_Sigmoid initialization

    A vulnerability was found in PyTorch 2.6.0+cu124. It has been rated as problematic. Affected by this issue is the function nnq_Sigmoid of the component Quantized Sigmoid Module. The manipulation of the argument scale/zero_point leads to improper initialization. The attack needs to be approached locally. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used.

  14. CVE-2025-2148

    Низкий · CVSS 2.3EPSS 0,44%Нет опубликованного исправления

    PyTorch Tuple torch.ops.profiler._call_end_callbacks_on_jit_fut memory corruption

    A vulnerability was found in PyTorch 2.6.0+cu124. It has been declared as critical. Affected by this vulnerability is the function torch.ops.profiler._call_end_callbacks_on_jit_fut of the component Tuple Handler. The manipulation of the argument None leads to memory corruption. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult.

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →