p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости haproxy

За последние 30 дней в haproxy опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 9

  1. CVE-2023-25725

    Критический · CVSS 9.1EPSS 5,45%Есть исправление

    CVE-2023-25725

    HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.

    • Обновитесь до 1.8.8-1ubuntu0.13
    Опубликовано Обновлено
  2. CVE-2020-11100

    Высокий · CVSS 8.8EPSS 61,59%Есть исправление

    CVE-2020-11100

    In hpack_dht_insert in hpack-tbl.c in the HPACK decoder in HAProxy 1.8 through 2.x before 2.1.4, a remote attacker can write arbitrary bytes around a certain location on the heap via a crafted HTTP/2 request, possibly causing remote code execution.

    • Обновитесь до 1.8.8-1ubuntu0.10
    Опубликовано Обновлено
  3. CVE-2019-19330

    Критический · CVSS 9.8EPSS 4,03%Есть исправление

    CVE-2019-19330

    The HTTP/2 implementation in HAProxy before 2.0.10 mishandles headers, as demonstrated by carriage return (CR, ASCII 0xd), line feed (LF, ASCII 0xa), and the zero character (NUL, ASCII 0x0), aka Intermediary Encapsulation Attacks.

    • Обновитесь до 1.8.8-1ubuntu0.9
    Опубликовано Обновлено
  4. CVE-2019-18277

    Высокий · CVSS 7.5EPSS 10,07%Есть исправление

    CVE-2019-18277

    A flaw was found in HAProxy before 2.0.6. In legacy mode, messages featuring a transfer-encoding header missing the "chunked" value were not being correctly rejected. The impact was limited but if combined with the "http-reuse always" setting, it could be used to help construct an HTTP request smuggling attack against a vulnerable component employing a lenient parser that would ignore the content-length header as soon as it saw a transfer-encoding one (even if not entirely valid according to the specification).

    • Обновитесь до 1.8.8-1ubuntu0.7
    Опубликовано Обновлено
  5. CVE-2018-20615

    Высокий · CVSS 7.5EPSS 4,46%Есть исправление

    CVE-2018-20615

    An out-of-bounds read issue was discovered in the HTTP/2 protocol decoder in HAProxy 1.8.x and 1.9.x through 1.9.0 which can result in a crash. The processing of the PRIORITY flag in a HEADERS frame requires 5 extra bytes, and while these bytes are skipped, the total frame length was not re-checked to make sure they were present in the frame.

    • Обновитесь до 1.8.8-1ubuntu0.3
    Опубликовано Обновлено
  6. CVE-2018-20103

    Высокий · CVSS 7.5EPSS 6,59%Есть исправление

    CVE-2018-20103

    An issue was discovered in dns.c in HAProxy through 1.8.14. In the case of a compressed pointer, a crafted packet can trigger infinite recursion by making the pointer point to itself, or create a long chain of valid pointers resulting in stack exhaustion.

    • Обновитесь до 1.8.8-1ubuntu0.3
    Опубликовано Обновлено
  7. CVE-2018-20102

    Высокий · CVSS 7.5EPSS 4,15%Есть исправление

    CVE-2018-20102

    An out-of-bounds read in dns_validate_dns_response in dns.c was discovered in HAProxy through 1.8.14. Due to a missing check when validating DNS responses, remote attackers might be able read the 16 bytes corresponding to an AAAA record from the non-initialized part of the buffer, possibly accessing anything that was left on the stack, or even past the end of the 8193-byte buffer, depending on the value of accepted_payload_size.

    • Обновитесь до 1.8.8-1ubuntu0.3
    Опубликовано Обновлено
  8. CVE-2018-14645

    Высокий · CVSS 7.5EPSS 3,07%Есть исправление

    CVE-2018-14645

    A flaw was discovered in the HPACK decoder of HAProxy, before 1.8.14, that is used for HTTP/2. An out-of-bounds read access in hpack_valid_idx() resulted in a remote crash and denial of service.

    • Обновитесь до 1.8.8-1ubuntu0.2
    Опубликовано Обновлено
  9. CVE-2018-11469

    Средний · CVSS 5.9EPSS 2,92%Есть исправление

    CVE-2018-11469

    Incorrect caching of responses to requests including an Authorization header in HAProxy 1.8.0 through 1.8.9 (if cache enabled) allows attackers to achieve information disclosure via an unauthenticated remote request, related to the proto_http.c check_request_for_cacheability function.

    • Обновитесь до 1.8.8-1ubuntu0.1

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →