p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости unbound

За последние 30 дней в unbound опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 24

  1. CVE-2024-8508

    Средний · CVSS 5.3EPSS 0,8%Есть исправление

    Unbounded name compression could lead to Denial of Service

    NLnet Labs Unbound up to and including version 1.21.0 contains a vulnerability when handling replies with very large RRsets that it needs to perform name compression for. Malicious upstreams responses with very large RRsets can cause Unbound to spend a considerable time applying name compression to downstream replies. This can lead to degraded performance and eventually denial of service in well orchestrated attacks. The vulnerability can be exploited by a malicious actor querying Unbound for the specially crafted contents of a malicious zone with very large RRsets. Before Unbound replies to the query it will try to apply name compression whi

    • Обновитесь до 1.9.4-2ubuntu1.9
    Опубликовано Обновлено
  2. CVE-2024-43168

    Средний · CVSS 4.8EPSS 0,31%Есть исправление

    Unbound: heap-buffer-overflow in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A heap-buffer-overflow flaw was found in the cfg_mark_ports function within Unbound's config_file.c, which can lead to memory corruption. This issue could allow an attacker

    • Обновитесь до 1.9.4-2ubuntu1.8
    Опубликовано Обновлено
  3. CVE-2024-43167

    Низкий · CVSS 2.8EPSS 0,39%Есть исправление

    Unbound: null pointer dereference in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A NULL pointer dereference flaw was found in the ub_ctx_set_fwd function in Unbound. This issue could allow an attacker who can invoke specific sequences of API calls to ca

    • Обновитесь до 1.9.4-2ubuntu1.8
    Опубликовано Обновлено
  4. CVE-2024-33655

    Высокий · CVSS 7.5EPSS 1,74%Есть исправление

    CVE-2024-33655

    The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service (resource consumption) by arranging for DNS queries to be accumulated for seconds, such that responses are later sent in a pulsing burst (which can be considered traffic amplification in some cases), aka the "DNSBomb" issue.

    • Обновитесь до 1.9.4-2ubuntu1.6
  5. CVE-2023-50868

    Высокий · CVSS 7.5EPSS 74,3%Есть исправление

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 1.9.4-2ubuntu1.5
    Опубликовано Обновлено
  6. CVE-2023-50387

    Высокий · CVSS 7.5EPSS 99,99%Есть исправление

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 1.9.4-2ubuntu1.5
    Опубликовано Обновлено
  7. CVE-2022-3204

    Высокий · CVSS 7.5EPSS 1,65%Есть исправление

    NRDelegation Attack

    A vulnerability named 'Non-Responsive Delegation Attack' (NRDelegation Attack) has been discovered in various DNS resolving software. The NRDelegation Attack works by having a malicious delegation with a considerable number of non responsive nameservers. The attack starts by querying a resolver for a record that relies on those unresponsive nameservers. The attack can cause a resolver to spend a lot of time/resources resolving records under a malicious delegation point where a considerable number of unresponsive NS records reside. It can trigger high CPU usage in some resolver implementations that continually look in the cache for resolved NS

    • Обновитесь до 1.9.4-2ubuntu1.4
  8. CVE-2022-30699

    Средний · CVSS 6.5EPSS 1,16%Есть исправление

    Novel "ghost domain names" attack by updating almost expired delegation information

    NLnet Labs Unbound, up to and including version 1.16.1, is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a rogue domain name when the cached delegation information is about to expire. The rogue nameserver delays the response so that the cached delegation information is expired. Upon receiving the delayed answer containing the delegation information, Unbound overwrites the now expired entries. This action can be repeated when the delegation information is about to expire making the rogue delegation information ever-updating. From version 1.16.2 on

    • Обновитесь до 1.9.4-2ubuntu1.3
    Опубликовано Обновлено
  9. CVE-2022-30698

    Средний · CVSS 6.5EPSS 1,16%Есть исправление

    Novel "ghost domain names" attack by introducing subdomain delegations

    NLnet Labs Unbound, up to and including version 1.16.1 is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a subdomain of a rogue domain name. The rogue nameserver returns delegation information for the subdomain that updates Unbound's delegation cache. This action can be repeated before expiry of the delegation information by querying Unbound for a second level subdomain which the rogue nameserver provides new delegation information. Since Unbound is a child-centric resolver, the ever-updating child delegation information can keep a rogue domain na

    • Обновитесь до 1.9.4-2ubuntu1.3
    Опубликовано Обновлено
  10. CVE-2019-25031

    Средний · CVSS 5.9EPSS 1,68%Есть исправление

    CVE-2019-25031

    Unbound before 1.9.5 allows configuration injection in create_unbound_ad_servers.sh upon a successful man-in-the-middle attack against a cleartext HTTP session. NOTE: The vendor does not consider this a vulnerability of the Unbound software. create_unbound_ad_servers.sh is a contributed script from the community that facilitates automatic configuration creation. It is not part of the Unbound installation

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  11. CVE-2019-25032

    Критический · CVSS 9.8EPSS 2,88%Есть исправление

    CVE-2019-25032

    Unbound before 1.9.5 allows an integer overflow in the regional allocator via regional_alloc. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  12. CVE-2019-25033

    Критический · CVSS 9.8EPSS 2,37%Есть исправление

    CVE-2019-25033

    Unbound before 1.9.5 allows an integer overflow in the regional allocator via the ALIGN_UP macro. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  13. CVE-2019-25034

    Критический · CVSS 9.8EPSS 2,88%Есть исправление

    CVE-2019-25034

    Unbound before 1.9.5 allows an integer overflow in sldns_str2wire_dname_buf_origin, leading to an out-of-bounds write. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  14. CVE-2019-25035

    Критический · CVSS 9.8EPSS 2,88%Есть исправление

    CVE-2019-25035

    Unbound before 1.9.5 allows an out-of-bounds write in sldns_bget_token_par. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  15. CVE-2019-25036

    Высокий · CVSS 7.5EPSS 2,07%Есть исправление

    CVE-2019-25036

    Unbound before 1.9.5 allows an assertion failure and denial of service in synth_cname. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  16. CVE-2019-25037

    Высокий · CVSS 7.5EPSS 2,15%Есть исправление

    CVE-2019-25037

    Unbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an invalid packet. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  17. CVE-2019-25038

    Критический · CVSS 9.8EPSS 2,81%Есть исправление

    CVE-2019-25038

    Unbound before 1.9.5 allows an integer overflow in a size calculation in dnscrypt/dnscrypt.c. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  18. CVE-2019-25039

    Критический · CVSS 9.8EPSS 2,88%Есть исправление

    CVE-2019-25039

    Unbound before 1.9.5 allows an integer overflow in a size calculation in respip/respip.c. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  19. CVE-2019-25040

    Высокий · CVSS 7.5EPSS 2,07%Есть исправление

    CVE-2019-25040

    Unbound before 1.9.5 allows an infinite loop via a compressed name in dname_pkt_copy. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено
  20. CVE-2019-25041

    Высокий · CVSS 7.5EPSS 2,15%Есть исправление

    CVE-2019-25041

    Unbound before 1.9.5 allows an assertion failure via a compressed name in dname_pkt_copy. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Обновитесь до 1.9.4-2ubuntu1.2
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →