p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости haproxy

За последние 30 дней в haproxy опубликовано уязвимостей: 2; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 12

  1. CVE-2026-110353

    Высокий · CVSS 7.5EPSS 0,74%Нет опубликованного исправления

    CVE-2026-110353

    HAProxy 3.2 before 3.4.6 allows a remote unauthenticated attacker to cause a denial of service (worker-thread CPU exhaustion) via a truncated HTTP/2 PING frame. h2c_handle_ping in src/mux_h2.c does not check for a short read, unlike the other H2 frame handlers. Because the incomplete frame cannot be processed, its data is never consumed, and the H2 multiplexer tasklet is repeatedly woken by that pending data without making progress. The CPU spins until timeout http-request closes the connection, and an attacker opening many such connections can sustain high CPU usage.

    Опубликовано Обновлено
  2. CVE-2026-110354

    Высокий · CVSS 7.5EPSS 0,81%Нет опубликованного исправления

    CVE-2026-110354

    HAProxy 3 before 3.4.6 allows a remote unauthenticated attacker to cause a denial of service (persistent worker-thread CPU exhaustion) via an HTTP/1.1 chunked request. Although the H1 multiplexer drains the request before closing the stream, the parser repeatedly re-processes the same bytes without making progress. The affected thread stays busy at 100% CPU after timeouts expire and after the client disconnects, and repeated requests can consume all worker threads until the process is restarted.

    Опубликовано Обновлено
  3. CVE-2026-55204

    Высокий · CVSS 8.7EPSS 0,48%Есть исправление

    HAProxy - NULL Pointer Dereference in hpack_dht_insert Function

    HAProxy through 3.4.0, fixed in commit 9a6d1fe, contains a null pointer dereference vulnerability in hpack_dht_insert() within src/hpack-tbl.c that fails to validate the return value of hpack_dht_defrag() when the memory pool is exhausted. An attacker can trigger HPACK dynamic table insertions under memory pressure to dereference a NULL pointer and crash HAProxy worker processes, causing denial of service.

    • Обновитесь до 2.4.30-0ubuntu0.22.04.2
  4. CVE-2026-55203

    Критический · CVSS 9EPSS 0,33%Есть исправление

    HAProxy - Integer Overflow in FCGI Demux Record Length Field

    HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers. When contentLength is 65535 and paddingLength is 1 or more, the drl field wraps to 0, causing incorrect record consumption and allowing malicious FastCGI backends to desynchronize the FCGI framing parser, potentially causing request routing errors, response smuggling, or memory safety issues.

    • Обновитесь до 2.4.30-0ubuntu0.22.04.2
  5. CVE-2025-11230

    Высокий · CVSS 7.5EPSS 0,74%Есть исправление

    Denial of service vulnerability in HAProxy mjson library

    Inefficient algorithm complexity in mjson in HAProxy allows remote attackers to cause a denial of service via specially crafted JSON requests.

    • Обновитесь до 2.4.24-0ubuntu0.22.04.3
    Опубликовано Обновлено
  6. CVE-2025-32464

    Средний · CVSS 6.8EPSS 0,76%Есть исправление

    CVE-2025-32464

    HAProxy 2.2 through 3.1.6, in certain uncommon configurations, has a sample_conv_regsub heap-based buffer overflow because of mishandling of the replacement of multiple short patterns with a longer one.

    • Обновитесь до 2.4.24-0ubuntu0.22.04.2
    Опубликовано Обновлено
  7. CVE-2023-45539

    Высокий · CVSS 8.2EPSS 1,51%Есть исправление

    CVE-2023-45539

    HAProxy before 2.8.2 accepts # as part of the URI component, which might allow remote attackers to obtain sensitive information or have unspecified other impact upon misinterpretation of a path_end rule, such as routing index.html#.png to a static server.

    • Обновитесь до 2.4.22-0ubuntu0.22.04.3
    Опубликовано Обновлено
  8. CVE-2023-40225

    Высокий · CVSS 7.2EPSS 2,15%Есть исправление

    CVE-2023-40225

    HAProxy through 2.0.32, 2.1.x and 2.2.x through 2.2.30, 2.3.x and 2.4.x through 2.4.23, 2.5.x and 2.6.x before 2.6.15, 2.7.x before 2.7.10, and 2.8.x before 2.8.2 forwards empty Content-Length headers, violating RFC 9110 section 8.6. In uncommon cases, an HTTP/1 server behind HAProxy may interpret the payload as an extra request.

    • Обновитесь до 2.4.22-0ubuntu0.22.04.2
    Опубликовано Обновлено
  9. CVE-2023-0836

    Высокий · CVSS 7.5EPSS 1,2%Есть исправление

    CVE-2023-0836

    An information leak vulnerability was discovered in HAProxy 2.1, 2.2 before 2.2.27, 2.3, 2.4 before 2.4.21, 2.5 before 2.5.11, 2.6 before 2.6.8, 2.7 before 2.7.1. There are 5 bytes left uninitialized in the connection buffer when encoding the FCGI_BEGIN_REQUEST record. Sensitive data may be disclosed to configured FastCGI backends in an unexpected way.

    • Обновитесь до 2.4.18-0ubuntu1.3
    Опубликовано Обновлено
  10. CVE-2023-0056

    Средний · CVSS 6.5EPSS 1,83%Есть исправление

    CVE-2023-0056

    An uncontrolled resource consumption vulnerability was discovered in HAProxy which could crash the service. This issue could allow an authenticated remote attacker to run a specially crafted malicious server in an OpenShift cluster. The biggest impact is to availability.

    • Обновитесь до 2.4.18-0ubuntu1.1
    Опубликовано Обновлено
  11. CVE-2023-25725

    Критический · CVSS 9.1EPSS 5,45%Есть исправление

    CVE-2023-25725

    HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.

    • Обновитесь до 2.4.18-0ubuntu1.2
    Опубликовано Обновлено
  12. CVE-2021-40346

    Высокий · CVSS 7.5EPSS 58,83%Есть исправление

    CVE-2021-40346

    An integer overflow exists in HAProxy 2.0 through 2.5 in htx_add_header that can be exploited to perform an HTTP request smuggling attack, allowing an attacker to bypass all configured http-request HAProxy ACLs and possibly other ACLs.

    • Обновитесь до 2.2.9-2ubuntu2
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →