p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости apache2 · Страница 2

За последние 30 дней в apache2 опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 31

  1. CVE-2026-34032

    Средний · CVSS 5.3EPSS 0,48%Есть исправление

    Apache HTTP Server: mod_proxy_ajp: Heap Buffer Over-Read Due to Missing Null-Termination Check (ajp_msg_get_string)

    Improper Null Termination, Out-of-bounds Read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

    • Обновитесь до 2.4.64-1ubuntu3.4
  2. CVE-2026-34059

    Высокий · CVSS 7.5EPSS 0,39%Есть исправление

    Apache HTTP Server: mod_proxy_ajp: Heap Over-Read and memory disclosure in ajp_parse_data()

    Buffer Over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

    • Обновитесь до 2.4.64-1ubuntu3.4
  3. CVE-2026-24072

    Высокий · CVSS 8.8EPSS 0,65%Есть исправление

    Apache HTTP Server: mod_rewrite elevation of privileges via ap_expr

    An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of the httpd user. Users are recommended to upgrade to version 2.4.67, which fixes this issue.

    • Обновитесь до 2.4.64-1ubuntu3.4
  4. USN-7968-2

    Без оценкиЕсть исправление

    apache2 regression

    USN-7968-1 fixed vulnerabilities in Apache HTTP Server. The update introduced a regression in mod_md where the MDStapleOthers setting was ignored which resulted in OCSP being broken for some domains. This update fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that the Apache HTTP Server incorrectly handled failed ACME certificate renewals. This could result in renewal attempts to be repeated without delays, possibly leading to a denial of service. (CVE-2025-55753) Anthony Parfenov discovered that the Apache HTTP Server would pass the query string to cmd directives when configured

    • Обновитесь до 2.4.64-1ubuntu3.3
  5. CVE-2025-58098

    Высокий · CVSS 8.3EPSS 1,42%Есть исправление

    Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...

    Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

    • Обновитесь до 2.4.64-1ubuntu3.2
    Опубликовано Обновлено
  6. CVE-2025-66200

    Средний · CVSS 5.4EPSS 0,65%Есть исправление

    Apache HTTP Server: mod_userdir+suexec bypass via AllowOverride FileInfo

    mod_userdir+suexec bypass via AllowOverride FileInfo vulnerability in Apache HTTP Server. Users with access to use the RequestHeader directive in htaccess can cause some CGI scripts to run under an unexpected userid. This issue affects Apache HTTP Server: from 2.4.7 through 2.4.65. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

    • Обновитесь до 2.4.64-1ubuntu3.2
    Опубликовано Обновлено
  7. CVE-2025-65082

    Средний · CVSS 6.5EPSS 0,81%Есть исправление

    Apache HTTP Server: CGI environment variable override

    Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.

    • Обновитесь до 2.4.64-1ubuntu3.2
    Опубликовано Обновлено
  8. CVE-2025-55753

    Высокий · CVSS 7.5EPSS 0,45%Есть исправление

    Apache HTTP Server: mod_md (ACME), unintended retry intervals

    An integer overflow in the case of failed ACME certificate renewal leads, after a number of failures (~30 days in default configurations), to the backoff timer becoming 0. Attempts to renew the certificate then are repeated without delays until it succeeds. This issue affects Apache HTTP Server: from 2.4.30 before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

    • Обновитесь до 2.4.64-1ubuntu3.2
    Опубликовано Обновлено
  9. CVE-2024-47252

    Высокий · CVSS 7.5EPSS 0,8%Есть исправление

    Apache HTTP Server: mod_ssl error log variable escaping

    Insufficient escaping of user-supplied data in mod_ssl in Apache HTTP Server 2.4.63 and earlier allows an untrusted SSL/TLS client to insert escape characters into log files in some configurations. In a logging configuration where CustomLog is used with "%{varname}x" or "%{varname}c" to log variables provided by mod_ssl such as SSL_TLS_SNI, no escaping is performed by either mod_log_config or mod_ssl and unsanitized data provided by the client may appear in log files.

    • Обновитесь до 2.4.64-1ubuntu2
  10. CVE-2024-43204

    Высокий · CVSS 7.5EPSS 0,91%Есть исправление

    Apache HTTP Server: SSRF with mod_headers setting Content-Type header

    SSRF in Apache HTTP Server with mod_proxy loaded allows an attacker to send outbound proxy requests to a URL controlled by the attacker.  Requires an unlikely configuration where mod_headers is configured to modify the Content-Type request or response header with a value provided in the HTTP request. Users are recommended to upgrade to version 2.4.64 which fixes this issue.

    • Обновитесь до 2.4.64-1ubuntu2
  11. CVE-2024-42516

    Высокий · CVSS 7.5EPSS 0,82%Есть исправление

    Apache HTTP Server: HTTP response splitting

    HTTP response splitting in the core of Apache HTTP Server allows an attacker who can manipulate the Content-Type response headers of applications hosted or proxied by the server can split the HTTP response. This vulnerability was described as CVE-2023-38709 but the patch included in Apache HTTP Server 2.4.59 did not address the issue. Users are recommended to upgrade to version 2.4.64, which fixes this issue.

    • Обновитесь до 2.4.64-1ubuntu2

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →