p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости heimdal

За последние 30 дней в heimdal опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 6

  1. CVE-2022-3116

    Высокий · CVSS 7.5EPSS 0,89%Нет опубликованного исправления

    CVE-2022-3116

    The Heimdal Software Kerberos 5 implementation is vulnerable to a null pointer dereferance. An attacker with network access to an application that depends on the vulnerable code path can cause the application to crash.

    Опубликовано Обновлено
  2. CVE-2022-45142

    Высокий · CVSS 7.5EPSS 0,49%Нет опубликованного исправления

    CVE-2022-45142

    The fix for CVE-2022-3437 included changing memcmp to be constant time and a workaround for a compiler bug by adding "!= 0" comparisons to the result of memcmp. When these patches were backported to the heimdal-7.7.1 and heimdal-7.8.0 branches (and possibly other branches) a logic inversion sneaked in causing the validation of message integrity codes in gssapi/arcfour to be inverted.

  3. CVE-2021-44758

    Высокий · CVSS 7.5EPSS 1,33%Нет опубликованного исправления

    CVE-2021-44758

    Heimdal before 7.7.1 allows attackers to cause a NULL pointer dereference in a SPNEGO acceptor via a preferred_mech_type of GSS_C_NO_OID and a nonzero initial_response value to send_accept.

    Опубликовано Обновлено
  4. CVE-2022-44640

    Критический · CVSS 9.8EPSS 2,35%Нет опубликованного исправления

    CVE-2022-44640

    Heimdal before 7.7.1 allows remote attackers to execute arbitrary code because of an invalid free in the ASN.1 codec used by the Key Distribution Center (KDC).

    Опубликовано Обновлено
  5. CVE-2022-42898

    Высокий · CVSS 8.8EPSS 6,86%Нет опубликованного исправления

    CVE-2022-42898

    PAC parsing in MIT Kerberos 5 (aka krb5) before 1.19.4 and 1.20.x before 1.20.1 has integer overflows that may lead to remote code execution (in KDC, kadmind, or a GSS or Kerberos application server) on 32-bit platforms (which have a resultant heap-based buffer overflow), and cause a denial of service on other platforms. This occurs in krb5_pac_parse in lib/krb5/krb/pac.c. Heimdal before 7.7.1 has "a similar bug."

    Опубликовано Обновлено
  6. CVE-2022-41916

    Средний · CVSS 5.9EPSS 1%Нет опубликованного исправления

    Read one byte past a buffer when normalizing Unicode

    Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →