p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости ironic

За последние 30 дней в ironic опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 14

  1. CVE-2026-54423

    Высокий · CVSS 8.2EPSS 0,3%Нет опубликованного исправления

    CVE-2026-54423

    In OpenStack Ironic before 37.0.1, an Ironic user with the ability to deploy nodes using the IPMI management interface can maliciously use the send_raw step to send arbitrary IPMI commands to a node, bypassing Ironic's access control.

  2. CVE-2026-54421

    Средний · CVSS 6.8EPSS 0,29%Нет опубликованного исправления

    CVE-2026-54421

    In OpenStack Ironic before 37.0.1, when applying a PATCH to update fields in volume properties the user is authorized for, Ironic can return unredacted sensitive information (such as iSCSI credentials). The PATCH outcome is a security issue; the POST outcome is not a security issue.

  3. CVE-2026-50589

    Средний · CVSS 5.3EPSS 0,43%Нет опубликованного исправления

    CVE-2026-50589

    In OpenStack Ironic 32 before 37.0.0, an unauthenticated malicious user could submit a crafted JSON string to some endpoints on the API or JSON-RPC service and effect a service crash.

  4. CVE-2026-48681

    Средний · CVSS 5.9EPSS 0,6%Есть исправление

    CVE-2026-48681

    OpenStack Ironic through before 35.0.2 allows file overwrite via directory traversal during deployment with a crafted ISO image.

    • Обновитесь до 1:32.0.0-0ubuntu1.1
  5. CVE-2026-44917

    Средний · CVSS 4.9EPSS 0,28%Есть исправление

    CVE-2026-44917

    OpenStack Ironic before 35.0.2 allows a malicious authenticated project admin or manager to read local files on the Ironic conductor via a pxe_template.

    • Обновитесь до 1:32.0.0-0ubuntu1.1
  6. CVE-2026-46447

    Средний · CVSS 5.8EPSS 0,26%Есть исправление

    CVE-2026-46447

    OpenStack Ironic before 35.0.2 allows Boot Script Injection of an iPXE script if the attacker can set node.driver_info or node.instance_info.

    • Обновитесь до 1:32.0.0-0ubuntu1.1
  7. CVE-2026-44919

    Средний · CVSS 4.3EPSS 0,47%Нет опубликованного исправления

    CVE-2026-44919

    In OpenStack Ironic through 35.x before a3f6d73, during image handling, an infinite loop in checksum calculations can occur via the file:///dev/zero URL.

  8. CVE-2026-42997

    Высокий · CVSS 7.7EPSS 0,43%Нет опубликованного исправления

    CVE-2026-42997

    An issue was discovered in idrac in OpenStack Ironic before 35.0.1. During import, a user invoking molds can request authorization to be sent to a remote endpoint. The credential forwarded is a time-limited Keystone token (which provides access to all OpenStack services Ironic is authorized for); or basic credentials configured for molds storage. The fixed versions are 26.1.6, 29.0.5, 32.0.1, and 35.0.1.

  9. CVE-2025-44021

    Низкий · CVSS 2.8EPSS 0,19%Нет опубликованного исправления

    CVE-2025-44021

    OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.

  10. CVE-2024-47211

    Средний · CVSS 5.3EPSS 0,66%Нет опубликованного исправления

    CVE-2024-47211

    In OpenStack Ironic before 21.4.4, 22.x and 23.x before 23.0.3, 23.x and 24.x before 24.1.3, and 25.x and 26.x before 26.1.0, there is a lack of checksum validation of supplied image_source URLs when configured to convert images to a raw format for streaming.

    Опубликовано Обновлено
  11. CVE-2024-44082

    Средний · CVSS 4.3EPSS 0,55%Нет опубликованного исправления

    CVE-2024-44082

    In OpenStack Ironic before 26.0.1 and ironic-python-agent before 9.13.1, there is a vulnerability in image processing, in which a crafted image could be used by an authenticated user to exploit undesired behaviors in qemu-img, including possible unauthorized access to potentially sensitive data. The affected/fixed version details are: Ironic: <21.4.3, >=22.0.0 <23.0.2, >=23.1.0 <24.1.2, >=25.0.0 <26.0.1; Ironic-python-agent: <9.4.2, >=9.5.0 <9.7.1, >=9.8.0 <9.11.1, >=9.12.0 <9.13.1.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →