p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости jquery

За последние 30 дней в jquery опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 5

  1. CVE-2020-7656

    Средний · CVSS 6.1EPSS 6,43%Публичный эксплойтНет опубликованного исправления

    CVE-2020-7656

    jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

  2. CVE-2020-11022

    Средний · CVSS 6.9EPSS 99,22%Публичный эксплойтЕсть исправление

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Обновитесь до 1.11.3+dfsg-4ubuntu0.1~esm1
    Опубликовано Обновлено
  3. CVE-2019-5428

    Без оценкиНет опубликованного исправления

    UBUNTU-CVE-2019-5428

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2019-11358. Reason: This candidate is a duplicate of CVE-2019-11358. Notes: All CVE users should reference CVE-2019-11358 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    Опубликовано Обновлено
  4. CVE-2019-11358

    Средний · CVSS 6.1EPSS 86,82%Публичный эксплойтЕсть исправление

    CVE-2019-11358

    jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

    • Обновитесь до 1.11.3+dfsg-4ubuntu0.1~esm1
    Опубликовано Обновлено
  5. CVE-2015-9251

    Средний · CVSS 6.1EPSS 29,73%Нет опубликованного исправления

    CVE-2015-9251

    jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →