p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости libphp-adodb

За последние 30 дней в libphp-adodb опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 6

  1. CVE-2025-54119

    Критический · CVSS 10EPSS 0,53%Нет опубликованного исправления

    ADOdb's sqlite3 driver allows SQL injection

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. In versions 5.22.9 and below, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. This is fixed in version 5.22.10. To workaround this issue, only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter.

    Опубликовано Обновлено
  2. CVE-2025-46337

    Критический · CVSS 10EPSS 0,74%Нет опубликованного исправления

    SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

  3. CVE-2021-3850

    Критический · CVSS 9.1EPSS 2,17%Есть исправление

    Authentication Bypass by Primary Weakness in adodb/adodb

    Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.

    • Обновитесь до 5.20.3-1ubuntu1+esm1
    Опубликовано Обновлено
  4. CVE-2016-4855

    Средний · CVSS 6.1EPSS 1,95%Есть исправление

    CVE-2016-4855

    Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    • Обновитесь до 5.20.3-1ubuntu1+esm1
  5. CVE-2016-7405

    Критический · CVSS 9.8EPSS 2,98%Есть исправление

    CVE-2016-7405

    The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

    • Обновитесь до 5.20.3-1ubuntu1+esm1
    Опубликовано Обновлено
  6. CVE-2011-3699

    Без оценкиEPSS 1,37%Нет опубликованного исправления

    CVE-2011-3699

    John Lim ADOdb Library for PHP 5.11 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by tests/test-active-record.php and certain other files.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →