p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости moodle · Страница 13

За последние 30 дней в moodle опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 323

  1. CVE-2020-25630

    Высокий · CVSS 7.5EPSS 1,36%Нет опубликованного исправления

    CVE-2020-25630

    A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

    Опубликовано Обновлено
  2. CVE-2020-25631

    Средний · CVSS 6.1EPSS 0,93%Нет опубликованного исправления

    CVE-2020-25631

    A vulnerability was found in Moodle 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 where it was possible to include JavaScript in a book's chapter title, which was not escaped on the "Add new chapter" page. This is fixed in 3.9.2, 3.8.5 and 3.7.8.

    Опубликовано Обновлено
  3. CVE-2020-25700

    Средний · CVSS 6.5EPSS 1,34%Нет опубликованного исправления

    CVE-2020-25700

    In moodle, some database module web services allowed students to add entries within groups they did not belong to. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Опубликовано Обновлено
  4. CVE-2020-25702

    Средний · CVSS 6.1EPSS 1,29%Нет опубликованного исправления

    CVE-2020-25702

    In Moodle, it was possible to include JavaScript when re-naming content bank items. Versions affected: 3.9 to 3.9.2. This is fixed in moodle 3.9.3 and 3.10.

    Опубликовано Обновлено
  5. CVE-2020-25703

    Средний · CVSS 5.3EPSS 1,54%Нет опубликованного исправления

    CVE-2020-25703

    The participants table download in Moodle always included user emails, but should have only done so when users' emails are not hidden. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5 and 3.7 to 3.7.8. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, and 3.10.

    Опубликовано Обновлено
  6. CVE-2020-25701

    Средний · CVSS 5.3EPSS 1,39%Нет опубликованного исправления

    CVE-2020-25701

    If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Опубликовано Обновлено
  7. CVE-2020-25698

    Высокий · CVSS 7.5EPSS 1,92%Нет опубликованного исправления

    CVE-2020-25698

    Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Опубликовано Обновлено
  8. CVE-2020-25699

    Высокий · CVSS 7.5EPSS 1,61%Нет опубликованного исправления

    CVE-2020-25699

    In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Опубликовано Обновлено
  9. CVE-2020-10738

    Высокий · CVSS 7.5EPSS 3%Нет опубликованного исправления

    CVE-2020-10738

    A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.

  10. CVE-2019-14880

    Средний · CVSS 4.8EPSS 1,11%Нет опубликованного исправления

    CVE-2019-14880

    A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. OAuth 2 providers who do not verify users' email address changes require additional verification during sign-up to reduce the risk of account compromise.

    Опубликовано Обновлено
  11. CVE-2019-14881

    Средний · CVSS 6.1EPSS 1,11%Нет опубликованного исправления

    CVE-2019-14881

    A vulnerability was found in moodle 3.7 before 3.7.3, where there is blind XSS reflected in some locations where user email is displayed.

    Опубликовано Обновлено
  12. CVE-2019-14884

    Средний · CVSS 6.1EPSS 0,93%Нет опубликованного исправления

    CVE-2019-14884

    A vulnerability was found in Moodle 3.7 before 3.73, 3.6 before 3.6.7 and 3.5 before 3.5.9, where a reflected XSS possible from some fatal error messages.

    Опубликовано Обновлено
  13. CVE-2019-18210

    Средний · CVSS 5.4EPSS 0,79%Нет опубликованного исправления

    CVE-2019-18210

    Persistent XSS in /course/modedit.php of Moodle through 3.7.2 allows authenticated users (Teacher and above) to inject JavaScript into the session of another user (e.g., enrolled student or site administrator) via the introeditor[text] parameter. NOTE: the discoverer and vendor disagree on whether Moodle customers have a reasonable expectation that anyone authenticated as a Teacher can be trusted with the ability to add arbitrary JavaScript (this ability is not documented on Moodle's Teacher_role page). Because the vendor has this expectation, they have stated "this report has been closed as a false positive, and not a bug."

    Опубликовано Обновлено
  14. CVE-2019-14879

    Средний · CVSS 4.2EPSS 0,71%Нет опубликованного исправления

    CVE-2019-14879

    A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).

    Опубликовано Обновлено
  15. CVE-2019-10186

    Средний · CVSS 6.5EPSS 1,09%Нет опубликованного исправления

    CVE-2019-10186

    A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. A sesskey (CSRF) token was not being utilised by the XML loading/unloading admin tool.

  16. CVE-2019-10187

    Средний · CVSS 4EPSS 0,86%Нет опубликованного исправления

    CVE-2019-10187

    A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.

  17. CVE-2019-10188

    Средний · CVSS 4EPSS 0,86%Нет опубликованного исправления

    CVE-2019-10188

    A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in a quiz group could modify group overrides for other groups in the same quiz.

  18. CVE-2019-10189

    Средний · CVSS 4EPSS 0,86%Нет опубликованного исправления

    CVE-2019-10189

    A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in an assignment group could modify group overrides for other groups in the same assignment.

  19. CVE-2019-10134

    Средний · CVSS 4.2EPSS 1,05%Нет опубликованного исправления

    CVE-2019-10134

    A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The size of users' private file uploads via email were not correctly checked, so their quota allowance could be exceeded.

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →