p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости phpmyadmin

За последние 30 дней в phpmyadmin опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 87

  1. CVE-2025-3573

    Средний · CVSS 5.3EPSS 0,36%Нет опубликованного исправления

    CVE-2025-3573

    Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.

    Опубликовано Обновлено
  2. CVE-2025-24530

    Средний · CVSS 6.4EPSS 0,42%Нет опубликованного исправления

    CVE-2025-24530

    An issue was discovered in phpMyAdmin 5.x before 5.2.2. An XSS vulnerability has been discovered for the check tables feature. A crafted table or database name could be used for XSS.

    Опубликовано Обновлено
  3. CVE-2023-25727

    Средний · CVSS 5.4EPSS 1,16%Нет опубликованного исправления

    CVE-2023-25727

    In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.

    Опубликовано Обновлено
  4. CVE-2020-22452

    Критический · CVSS 9.8EPSS 1,71%Нет опубликованного исправления

    CVE-2020-22452

    SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.

  5. CVE-2022-0813

    Средний · CVSS 5.3EPSS 1,3%Нет опубликованного исправления

    PhpMyAdmin exposure of sensitive information

    PhpMyAdmin 5.1.1 and before allows an attacker to retrieve potentially sensitive information by creating invalid requests. This affects the lang parameter, the pma_parameter, and the cookie section.

    Опубликовано Обновлено
  6. CVE-2021-21252

    Средний · CVSS 5.3EPSS 3,57%Нет опубликованного исправления

    Regular expression denial of service in jquery-validation

    The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

    Опубликовано Обновлено
  7. CVE-2020-10802

    Высокий · CVSS 8EPSS 1,82%Нет опубликованного исправления

    CVE-2020-10802

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

    Опубликовано Обновлено
  8. CVE-2020-10803

    Средний · CVSS 5.4EPSS 1,37%Нет опубликованного исправления

    CVE-2020-10803

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results (in tbl_get_field.php and libraries/classes/Display/Results.php). The attacker must be able to insert crafted data into certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.

    Опубликовано Обновлено
  9. CVE-2020-10804

    Высокий · CVSS 8EPSS 2,35%Нет опубликованного исправления

    CVE-2020-10804

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

    Опубликовано Обновлено
  10. CVE-2020-5504

    Высокий · CVSS 8.8EPSS 39,04%Публичный эксплойтЕсть исправление

    CVE-2020-5504

    In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

    • Обновитесь до 4:4.5.4.1-2ubuntu2.1+esm6
    Опубликовано Обновлено
  11. CVE-2019-19617

    Критический · CVSS 9.8EPSS 2,27%Есть исправление

    CVE-2019-19617

    phpMyAdmin before 4.9.2 does not escape certain Git information, related to libraries/classes/Display/GitRevision.php and libraries/classes/Footer.php.

    • Обновитесь до 4:4.5.4.1-2ubuntu2.1+esm4
    Опубликовано Обновлено
  12. CVE-2019-12922

    Средний · CVSS 6.5EPSS 10,67%Публичный эксплойтЕсть исправление

    CVE-2019-12922

    A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.

    • Обновитесь до 4:4.5.4.1-2ubuntu2.1+esm3
    Опубликовано Обновлено
  13. CVE-2019-12616

    Средний · CVSS 6.5EPSS 20,22%Публичный эксплойтЕсть исправление

    CVE-2019-12616

    An issue was discovered in phpMyAdmin before 4.9.0. A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) to the victim.

    • Обновитесь до 4:4.5.4.1-2ubuntu2.1+esm3
  14. CVE-2019-11768

    Критический · CVSS 9.8EPSS 3,55%Есть исправление

    CVE-2019-11768

    An issue was discovered in phpMyAdmin before 4.9.0.1. A vulnerability was reported where a specially crafted database name can be used to trigger an SQL injection attack through the designer feature.

    • Обновитесь до 4:4.5.4.1-2ubuntu2.1+esm3
  15. CVE-2019-6799

    Средний · CVSS 5.9EPSS 14,83%Публичный эксплойтНет опубликованного исправления

    CVE-2019-6799

    An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of "options(MYSQLI_OPT_LOCAL_INFILE" calls.

    Опубликовано Обновлено
  16. CVE-2019-6798

    Критический · CVSS 9.8EPSS 3,58%Есть исправление

    CVE-2019-6798

    An issue was discovered in phpMyAdmin before 4.8.5. A vulnerability was reported where a specially crafted username can be used to trigger a SQL injection attack through the designer feature.

    • Обновитесь до 4:4.5.4.1-2ubuntu2.1+esm3
    Опубликовано Обновлено
  17. CVE-2018-19970

    Средний · CVSS 6.1EPSS 2,24%Есть исправление

    CVE-2018-19970

    In phpMyAdmin before 4.8.4, an XSS vulnerability was found in the navigation tree, where an attacker can deliver a payload to a user through a crafted database/table name.

    • Обновитесь до 4:4.5.4.1-2ubuntu2.1+esm3
    Опубликовано Обновлено
  18. CVE-2018-19969

    Высокий · CVSS 8.8EPSS 1,06%Нет опубликованного исправления

    CVE-2018-19969

    phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →