p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости ffmpeg · Страница 5

За последние 30 дней в ffmpeg опубликовано уязвимостей: 10; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 98

  1. CVE-2023-6602

    Средний · CVSS 5.3EPSS 0,51%Нет опубликованного исправления

    Ffmpeg: improper handling of input format in tty demuxer of ffmpeg

    A flaw was found in FFmpeg's TTY Demuxer. This vulnerability allows possible data exfiltration via improper parsing of non-TTY-compliant input files in HLS playlists.

    Опубликовано Обновлено
  2. CVE-2024-36619

    Средний · CVSS 5.3EPSS 0,68%Есть исправление

    CVE-2024-36619

    FFmpeg n6.1.1 has a vulnerability in the WAVARC decoder of the libavcodec library which allows for an integer overflow when handling certain block types, leading to a denial-of-service (DoS) condition.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm5
    Опубликовано Обновлено
  3. CVE-2024-36618

    Средний · CVSS 6.2EPSS 0,25%Есть исправление

    CVE-2024-36618

    FFmpeg n6.1.1 has a vulnerability in the AVI demuxer of the libavformat library which allows for an integer overflow, potentially resulting in a denial-of-service (DoS) condition.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm5
    Опубликовано Обновлено
  4. CVE-2024-36616

    Средний · CVSS 6.5EPSS 0,58%Есть исправление

    CVE-2024-36616

    An integer overflow in the component /libavformat/westwood_vqa.c of FFmpeg n6.1.1 allows attackers to cause a denial of service in the application via a crafted VQA file.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm5
    Опубликовано Обновлено
  5. CVE-2024-35368

    Критический · CVSS 9.8EPSS 0,71%Есть исправление

    CVE-2024-35368

    FFmpeg n7.0 is affected by a Double Free via the rkmpp_retrieve_frame function within libavcodec/rkmppdec.c.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm5
    Опубликовано Обновлено
  6. CVE-2024-35367

    Критический · CVSS 9.1EPSS 0,69%Есть исправление

    CVE-2024-35367

    FFmpeg n6.1.1 has an Out-of-bounds Read via libavcodec/ppc/vp8dsp_altivec.c, static const vec_s8 h_subpel_filters_outer

    • Обновитесь до 7:6.1.1-3ubuntu5+esm5
    Опубликовано Обновлено
  7. CVE-2024-35366

    Критический · CVSS 9.1EPSS 0,65%Есть исправление

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm5
    Опубликовано Обновлено
  8. CVE-2024-7055

    Средний · CVSS 6.9EPSS 1,44%Есть исправление

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm5
    Опубликовано Обновлено
  9. CVE-2023-50008

    Высокий · CVSS 7.8EPSS 0,37%Есть исправление

    CVE-2023-50008

    FFmpeg v.n6.1-3-g466799d4f5 allows memory consumption when using the colorcorrect filter, in the av_malloc function in libavutil/mem.c:105:9 component.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm1
  10. CVE-2023-50007

    Средний · CVSS 4EPSS 0,35%Есть исправление

    CVE-2023-50007

    FFmpeg v.n6.1-3-g466799d4f5 allows an attacker to trigger use of a parameter of negative size in the av_samples_set_silence function in thelibavutil/samplefmt.c:260:9 component.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm1
  11. CVE-2023-49502

    Высокий · CVSS 8.8EPSS 1,54%Есть исправление

    CVE-2023-49502

    Buffer Overflow vulnerability in Ffmpeg v.n6.1-3-g466799d4f5 allows a local attacker to execute arbitrary code via the ff_bwdif_filter_intra_c function in the libavfilter/bwdifdsp.c:125:5 component.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm1
    Опубликовано Обновлено
  12. CVE-2023-49501

    Высокий · CVSS 8EPSS 0,39%Есть исправление

    CVE-2023-49501

    Buffer Overflow vulnerability in Ffmpeg v.n6.1-3-g466799d4f5 allows a local attacker to execute arbitrary code via the config_eq_output function in the libavfilter/asrc_afirsrc.c:495:30 component.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm1
    Опубликовано Обновлено
  13. CVE-2024-31582

    Высокий · CVSS 7.8EPSS 0,34%Есть исправление

    CVE-2024-31582

    FFmpeg version n6.1 was discovered to contain a heap buffer overflow vulnerability in the draw_block_rectangle function of libavfilter/vf_codecview.c. This vulnerability allows attackers to cause undefined behavior or a Denial of Service (DoS) via crafted input.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm1
    Опубликовано Обновлено
  14. CVE-2023-49528

    Высокий · CVSS 8EPSS 0,4%Есть исправление

    CVE-2023-49528

    Buffer Overflow vulnerability in FFmpeg version n6.1-3-g466799d4f5, allows a local attacker to execute arbitrary code and cause a denial of service (DoS) via the af_dialoguenhance.c:261:5 in the de_stereo component.

    • Обновитесь до 7:6.1.1-3ubuntu5+esm1
    Опубликовано Обновлено
  15. CVE-2014-5271

    Без оценкиEPSS 4,7%Нет опубликованного исправления

    CVE-2014-5271

    Heap-based buffer overflow in the encode_slice function in libavcodec/proresenc_kostya.c in FFMpeg before 1.1.14, 1.2.x before 1.2.8, 2.x before 2.2.7, and 2.3.x before 2.3.3 and Libav before 10.5 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →