p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости ffmpeg · Страница 5

За последние 30 дней в ffmpeg опубликовано уязвимостей: 10; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 418

  1. CVE-2024-35368

    Критический · CVSS 9.8EPSS 0,71%Есть исправление

    CVE-2024-35368

    FFmpeg n7.0 is affected by a Double Free via the rkmpp_retrieve_frame function within libavcodec/rkmppdec.c.

    • Обновитесь до 7:5.1.7-0+deb12u1
    Опубликовано Обновлено
  2. CVE-2024-35367

    Критический · CVSS 9.1EPSS 0,68%Есть исправление

    CVE-2024-35367

    FFmpeg n6.1.1 has an Out-of-bounds Read via libavcodec/ppc/vp8dsp_altivec.c, static const vec_s8 h_subpel_filters_outer

    • Обновитесь до 7:5.1.7-0+deb12u1
    Опубликовано Обновлено
  3. CVE-2024-35366

    Критический · CVSS 9.1EPSS 0,65%Есть исправление

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Обновитесь до 7:5.1.5-0+deb12u1
    Опубликовано Обновлено
  4. CVE-2024-7272

    Средний · CVSS 6.9EPSS 1,2%Есть исправление

    FFmpeg swresample.c fill_audiodata heap-based overflow

    A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

    • Обновитесь до 7:5.1.6-0+deb12u1
    Опубликовано Обновлено
  5. CVE-2024-7055

    Средний · CVSS 6.9EPSS 1,44%Есть исправление

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Обновитесь до 7:5.1.6-0+deb12u1
    Опубликовано Обновлено
  6. CVE-2023-51794

    Высокий · CVSS 7.8EPSS 0,22%Есть исправление

    CVE-2023-51794

    Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via the libavfilter/af_stereowiden.c:120:69.

    • Обновитесь до 7:5.1.5-0+deb12u1
    Опубликовано Обновлено
  7. CVE-2023-51798

    Высокий · CVSS 7.8EPSS 0,32%Есть исправление

    CVE-2023-51798

    Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via a floating point exception (FPE) error at libavfilter/vf_minterpolate.c:1078:60 in interpolate.

    • Обновитесь до 7:5.1.5-0+deb12u1
    Опубликовано Обновлено
  8. CVE-2023-51795

    Высокий · CVSS 8EPSS 0,27%Есть исправление

    CVE-2023-51795

    Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via the libavfilter/avf_showspectrum.c:1789:52 component in showspectrumpic_request_frame

    • Обновитесь до 7:5.1.5-0+deb12u1
    Опубликовано Обновлено
  9. CVE-2023-51793

    Высокий · CVSS 7.8EPSS 0,32%Есть исправление

    CVE-2023-51793

    Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via the libavutil/imgutils.c:353:9 in image_copy_plane.

    • Обновитесь до 7:5.1.5-0+deb12u1
    Опубликовано Обновлено
  10. CVE-2023-50010

    Высокий · CVSS 7.8EPSS 0,48%Есть исправление

    CVE-2023-50010

    FFmpeg v.n6.1-3-g466799d4f5 allows a buffer over-read at ff_gradfun_blur_line_movdqa_sse2, as demonstrated by a call to the set_encoder_id function in /fftools/ffmpeg_enc.c component.

    • Обновитесь до 7:5.1.5-0+deb12u1
  11. CVE-2023-50008

    Высокий · CVSS 7.8EPSS 0,37%Есть исправление

    CVE-2023-50008

    FFmpeg v.n6.1-3-g466799d4f5 allows memory consumption when using the colorcorrect filter, in the av_malloc function in libavutil/mem.c:105:9 component.

    • Обновитесь до 7:5.1.7-0+deb12u1
  12. CVE-2023-50007

    Средний · CVSS 4EPSS 0,35%Есть исправление

    CVE-2023-50007

    FFmpeg v.n6.1-3-g466799d4f5 allows an attacker to trigger use of a parameter of negative size in the av_samples_set_silence function in thelibavutil/samplefmt.c:260:9 component.

    • Обновитесь до 7:5.1.7-0+deb12u1
  13. CVE-2023-49502

    Высокий · CVSS 8.8EPSS 1,53%Есть исправление

    CVE-2023-49502

    Buffer Overflow vulnerability in Ffmpeg v.n6.1-3-g466799d4f5 allows a local attacker to execute arbitrary code via the ff_bwdif_filter_intra_c function in the libavfilter/bwdifdsp.c:125:5 component.

    • Обновитесь до 7:5.1.7-0+deb12u1
    Опубликовано Обновлено
  14. CVE-2024-31585

    Средний · CVSS 5.3EPSS 0,33%Есть исправление

    CVE-2024-31585

    FFmpeg version n5.1 to n6.1 was discovered to contain an Off-by-one Error vulnerability in libavfilter/avf_showspectrum.c. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.

    • Обновитесь до 7:5.1.5-0+deb12u1
  15. CVE-2024-31582

    Высокий · CVSS 7.8EPSS 0,34%Есть исправление

    CVE-2024-31582

    FFmpeg version n6.1 was discovered to contain a heap buffer overflow vulnerability in the draw_block_rectangle function of libavfilter/vf_codecview.c. This vulnerability allows attackers to cause undefined behavior or a Denial of Service (DoS) via crafted input.

    • Обновитесь до 7:5.1.7-0+deb12u1
    Опубликовано Обновлено
  16. CVE-2023-49528

    Высокий · CVSS 8EPSS 0,4%Нет опубликованного исправления

    CVE-2023-49528

    Buffer Overflow vulnerability in FFmpeg version n6.1-3-g466799d4f5, allows a local attacker to execute arbitrary code and cause a denial of service (DoS) via the af_dialoguenhance.c:261:5 in the de_stereo component.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →