p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости qtbase-opensource-src · Страница 2

За последние 30 дней в qtbase-opensource-src опубликовано уязвимостей: 3; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 38

  1. CVE-2022-25255

    Высокий · CVSS 7.8EPSS 0,33%Есть исправление

    CVE-2022-25255

    In Qt 5.9.x through 5.15.x before 5.15.9 and 6.x before 6.2.4 on Linux and UNIX, QProcess could execute a binary from the current working directory when not found in the PATH.

    • Обновитесь до 5.15.2+dfsg-15
    Опубликовано Обновлено
  2. CVE-2020-24742

    Высокий · CVSS 7.8EPSS 1,17%Есть исправление

    CVE-2020-24742

    An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.

    • Обновитесь до 5.12.5+dfsg-8
    Опубликовано Обновлено
  3. CVE-2020-0569

    Средний · CVSS 5.7EPSS 0,56%Есть исправление

    CVE-2020-0569

    Out of bounds write in Intel(R) PROSet/Wireless WiFi products on Windows 10 may allow an authenticated user to potentially enable denial of service via local access.

    • Обновитесь до 5.12.5+dfsg-8
    Опубликовано Обновлено
  4. CVE-2020-0570

    Высокий · CVSS 7.3EPSS 0,57%Есть исправление

    CVE-2020-0570

    Uncontrolled search path in the QT Library before 5.14.0, 5.12.7 and 5.9.10 may allow an authenticated user to potentially enable elevation of privilege via local access.

    • Обновитесь до 5.12.5+dfsg-8
    Опубликовано Обновлено
  5. CVE-2020-17507

    Средний · CVSS 5.3EPSS 3,99%Есть исправление

    CVE-2020-17507

    An issue was discovered in Qt through 5.12.9, and 5.13.x through 5.15.x before 5.15.1. read_xbm_body in gui/image/qxbmhandler.cpp has a buffer over-read.

    • Обновитесь до 5.14.2+dfsg-6
    Опубликовано Обновлено
  6. CVE-2020-13962

    Высокий · CVSS 7.5EPSS 3,06%Есть исправление

    CVE-2020-13962

    Qt 5.12.2 through 5.14.2, as used in unofficial builds of Mumble 1.3.0 and other products, mishandles OpenSSL's error queue, which can cause a denial of service to QSslSocket users. Because errors leak in unrelated TLS sessions, an unrelated session may be disconnected when any handshake fails. (Mumble 1.3.1 is not affected, regardless of the Qt version.)

    • Обновитесь до 5.14.2+dfsg-6
  7. CVE-2015-9541

    Высокий · CVSS 7.5EPSS 2,59%Есть исправление

    CVE-2015-9541

    Qt through 5.14 allows an exponential XML entity expansion attack via a crafted SVG document that is mishandled in QXmlStreamReader, a related issue to CVE-2003-1564.

    • Обновитесь до 5.12.5+dfsg-9
    Опубликовано Обновлено
  8. CVE-2019-18281

    Средний · CVSS 4.3EPSS 2,05%Есть исправление

    CVE-2019-18281

    An out-of-bounds memory access in the generateDirectionalRuns() function in qtextengine.cpp in Qt qtbase 5.11.x and 5.12.x before 5.12.5 allows attackers to cause a denial of service by crashing an application via a text file containing many directional characters.

    • Обновитесь до 5.12.5+dfsg-2
    Опубликовано Обновлено
  9. CVE-2018-19872

    Средний · CVSS 5.5EPSS 1,38%Есть исправление

    CVE-2018-19872

    An issue was discovered in Qt 5.11. A malformed PPM image causes a division by zero and a crash in qppmhandler.cpp.

    • Обновитесь до 5.11.2+dfsg-3
    Опубликовано Обновлено
  10. CVE-2018-19873

    Критический · CVSS 9.8EPSS 3,38%Есть исправление

    CVE-2018-19873

    An issue was discovered in Qt before 5.11.3. QBmpHandler has a buffer overflow via BMP data.

    • Обновитесь до 5.11.3+dfsg-2
    Опубликовано Обновлено
  11. CVE-2018-19870

    Высокий · CVSS 8.8EPSS 2,42%Есть исправление

    CVE-2018-19870

    An issue was discovered in Qt before 5.11.3. A malformed GIF image causes a NULL pointer dereference in QGifHandler resulting in a segmentation fault.

    • Обновитесь до 5.11.3+dfsg-2
    Опубликовано Обновлено
  12. CVE-2018-15518

    Высокий · CVSS 8.8EPSS 2,5%Есть исправление

    CVE-2018-15518

    QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.

    • Обновитесь до 5.11.3+dfsg-2
    Опубликовано Обновлено
  13. CVE-2016-10040

    Средний · CVSS 5.5EPSS 1,92%Есть исправление

    CVE-2016-10040

    Stack-based buffer overflow in QXmlSimpleReader in Qt 4.8.5 allows remote attackers to cause a denial of service (application crash) via a xml file with multiple nested open tags.

    • Обновитесь до 5.2.0+dfsg-7
    Опубликовано Обновлено
  14. CVE-2015-1860

    Без оценкиEPSS 8,34%Есть исправление

    CVE-2015-1860

    Multiple buffer overflows in gui/image/qgifhandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a crafted GIF image.

    • Обновитесь до 5.3.2+dfsg-5
  15. CVE-2015-1859

    Без оценкиEPSS 6,54%Есть исправление

    CVE-2015-1859

    Multiple buffer overflows in plugins/imageformats/ico/qicohandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted ICO image.

    • Обновитесь до 5.3.2+dfsg-5
  16. CVE-2015-1858

    Без оценкиEPSS 6,57%Есть исправление

    CVE-2015-1858

    Multiple buffer overflows in gui/image/qbmphandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted BMP image.

    • Обновитесь до 5.3.2+dfsg-5
  17. CVE-2015-0295

    Без оценкиEPSS 6,07%Есть исправление

    CVE-2015-0295

    The BMP decoder in QtGui in QT before 5.5 does not properly calculate the masks used to extract the color components, which allows remote attackers to cause a denial of service (divide-by-zero and crash) via a crafted BMP file.

    • Обновитесь до 5.3.2+dfsg-5
    Опубликовано Обновлено
  18. CVE-2013-4549

    Без оценкиEPSS 3,1%Есть исправление

    CVE-2013-4549

    QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

    • Обновитесь до 5.1.1+dfsg-6
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →