p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости ffmpeg · Страница 5

За последние 30 дней в ffmpeg опубликовано уязвимостей: 10; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 436

  1. CVE-2023-6601

    Средний · CVSS 4.7EPSS 0,42%Есть исправление

    Ffmpeg: hls unsafe file extension bypass in ffmpeg

    A flaw was found in FFmpeg's HLS demuxer. This vulnerability allows bypassing unsafe file extension checks and triggering arbitrary demuxers via base64-encoded data URIs appended with specific file extensions.

    • Обновитесь до 7:6.1-1
    Опубликовано Обновлено
  2. CVE-2024-36613

    Средний · CVSS 6.2EPSS 0,28%Есть исправление

    CVE-2024-36613

    FFmpeg n6.1.1 has a vulnerability in the DXA demuxer of the libavformat library allowing for an integer overflow, potentially resulting in a denial-of-service (DoS) condition or other undefined behavior.

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено
  3. CVE-2024-35365

    Высокий · CVSS 8.8EPSS 0,67%Есть исправление

    CVE-2024-35365

    FFmpeg version n6.1.1 has a double-free vulnerability in the fftools/ffmpeg_mux_init.c component of FFmpeg, specifically within the new_stream_audio function.

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено
  4. CVE-2023-6603

    Высокий · CVSS 7.5EPSS 0,58%Есть исправление

    Ffmpeg: null pointer dereference in ffmpeg hls parsing

    A flaw was found in FFmpeg's HLS playlist parsing. This vulnerability allows a denial of service via a maliciously crafted HLS playlist that triggers a null pointer dereference during initialization.

    • Обновитесь до 7:5.0.1-2
    Опубликовано Обновлено
  5. CVE-2023-6602

    Средний · CVSS 5.3EPSS 0,51%Есть исправление

    Ffmpeg: improper handling of input format in tty demuxer of ffmpeg

    A flaw was found in FFmpeg's TTY Demuxer. This vulnerability allows possible data exfiltration via improper parsing of non-TTY-compliant input files in HLS playlists.

    • Обновитесь до 7:7.1.1-1
    Опубликовано Обновлено
  6. CVE-2024-36619

    Средний · CVSS 5.3EPSS 0,68%Есть исправление

    CVE-2024-36619

    FFmpeg n6.1.1 has a vulnerability in the WAVARC decoder of the libavcodec library which allows for an integer overflow when handling certain block types, leading to a denial-of-service (DoS) condition.

    • Обновитесь до 7:7.1-3
    Опубликовано Обновлено
  7. CVE-2024-36618

    Средний · CVSS 6.2EPSS 0,25%Есть исправление

    CVE-2024-36618

    FFmpeg n6.1.1 has a vulnerability in the AVI demuxer of the libavformat library which allows for an integer overflow, potentially resulting in a denial-of-service (DoS) condition.

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено
  8. CVE-2024-36616

    Средний · CVSS 6.5EPSS 0,58%Есть исправление

    CVE-2024-36616

    An integer overflow in the component /libavformat/westwood_vqa.c of FFmpeg n6.1.1 allows attackers to cause a denial of service in the application via a crafted VQA file.

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено
  9. CVE-2024-36615

    Средний · CVSS 5.9EPSS 0,44%Есть исправление

    CVE-2024-36615

    FFmpeg n7.0 has a race condition vulnerability in the VP9 decoder. This could lead to a data race if video encoding parameters were being exported, as the side data would be attached in the decoder thread while being read in the output thread.

    • Обновитесь до 7:7.1-3
    Опубликовано Обновлено
  10. CVE-2024-35369

    Средний · CVSS 5.5EPSS 0,24%Есть исправление

    CVE-2024-35369

    In FFmpeg version n6.1.1, specifically within the avcodec/speexdec.c module, a potential security vulnerability exists due to insufficient validation of certain parameters when parsing Speex codec extradata. This vulnerability could lead to integer overflow conditions, potentially resulting in undefined behavior or crashes during the decoding process.

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено
  11. CVE-2024-35367

    Критический · CVSS 9.1EPSS 0,68%Есть исправление

    CVE-2024-35367

    FFmpeg n6.1.1 has an Out-of-bounds Read via libavcodec/ppc/vp8dsp_altivec.c, static const vec_s8 h_subpel_filters_outer

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено
  12. CVE-2024-35366

    Критический · CVSS 9.1EPSS 0,65%Есть исправление

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено
  13. CVE-2024-7272

    Средний · CVSS 6.9EPSS 1,2%Есть исправление

    FFmpeg swresample.c fill_audiodata heap-based overflow

    A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

    • Обновитесь до 7:6.0-4
    Опубликовано Обновлено
  14. CVE-2024-7055

    Средний · CVSS 6.9EPSS 1,44%Есть исправление

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Обновитесь до 7:7.0.2-1
    Опубликовано Обновлено
  15. CVE-2023-51798

    Высокий · CVSS 7.8EPSS 0,32%Есть исправление

    CVE-2023-51798

    Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via a floating point exception (FPE) error at libavfilter/vf_minterpolate.c:1078:60 in interpolate.

    • Обновитесь до 7:7.0.1-3
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →