p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости spice

За последние 30 дней в spice опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 13

  1. CVE-2019-3813

    Высокий · CVSS 7.5EPSS 1,21%Есть исправление

    CVE-2019-3813

    Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.8
    Опубликовано Обновлено
  2. CVE-2018-10873

    Высокий · CVSS 8.3EPSS 3,93%Есть исправление

    CVE-2018-10873

    A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.7
    Опубликовано Обновлено
  3. CVE-2016-9578

    Высокий · CVSS 7.5EPSS 2,46%Есть исправление

    CVE-2016-9578

    A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An attacker able to connect to the SPICE server could send crafted messages which would cause the process to crash.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.4
  4. CVE-2016-9577

    Высокий · CVSS 7.5EPSS 3,79%Есть исправление

    CVE-2016-9577

    A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.4
  5. CVE-2017-12194

    Критический · CVSS 9.8EPSS 5,25%Есть исправление

    CVE-2017-12194

    A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.6
    Опубликовано Обновлено
  6. CVE-2017-7506

    Высокий · CVSS 8.8EPSS 4,2%Есть исправление

    CVE-2017-7506

    spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted messages from authenticated attacker to the spice server resulting into crash and/or server memory leak.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.5
  7. CVE-2016-2150

    Высокий · CVSS 7.1EPSS 0,36%Есть исправление

    CVE-2016-2150

    SPICE allows local guest OS users to read from or write to arbitrary host memory locations via crafted primary surface parameters, a similar issue to CVE-2015-5261.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.3
  8. CVE-2016-0749

    Критический · CVSS 9.8EPSS 8,49%Есть исправление

    CVE-2016-0749

    The smartcard interaction in SPICE allows remote attackers to cause a denial of service (QEMU-KVM process crash) or possibly execute arbitrary code via vectors related to connecting to a guest VM, which triggers a heap-based buffer overflow.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.3
  9. CVE-2015-5261

    Высокий · CVSS 7.1EPSS 0,47%Есть исправление

    CVE-2015-5261

    Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to read and write to arbitrary memory locations on the host via guest QXL commands related to surface creation.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.2
  10. CVE-2015-5260

    Высокий · CVSS 7.8EPSS 0,55%Есть исправление

    CVE-2015-5260

    Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via QXL commands related to the surface_id parameter.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.2
  11. CVE-2015-3247

    Без оценкиEPSS 1,14%Есть исправление

    CVE-2015-3247

    Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via unspecified vectors.

    • Обновитесь до 0.12.4-0nocelt2ubuntu1.1
    Опубликовано Обновлено
  12. CVE-2013-4282

    Без оценкиEPSS 2,73%Есть исправление

    CVE-2013-4282

    Stack-based buffer overflow in the reds_handle_ticket function in server/reds.c in SPICE 0.12.0 allows remote attackers to cause a denial of service (crash) via a long password in a SPICE ticket.

    • Обновитесь до 0.12.4-0nocelt1.1ubuntu1
    Опубликовано Обновлено
  13. CVE-2013-4130

    Без оценкиEPSS 2,63%Есть исправление

    CVE-2013-4130

    The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might allow remote attackers to cause a denial of service (reachable assertion and server exit) by triggering a network error.

    • Обновитесь до 0.12.4-0nocelt1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →